Help, files on server not showing on the web

Discussion in 'Free Hosting' started by allisgod, Jul 14, 2017.

  1. allisgod

    allisgod New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    hello all

    I uploaded files through ftp to the server, I can see them on the server but they are not getting published live to the web. And update made on home page is not getting updated to the web.
    What can cause this?
    My website is: http://theonlypresenceisgod.com
    I can give access to my c panel and file manager if any one will like to help.
    Please let me know.

    Thanks

    Mike
     
  2. akx10mxa

    akx10mxa New Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    I have the same issue. It's been 3 hours since I ftp'd a file and it still does not show.
    I can see and edit it in cpanel and the correct one is there but when I load my page and show source code it's wrong.
    I'm working with a .js file that has java script in it. Because of one line error, every function in the file dies.
    Not sure how long to wait. I have found this typical though. Sometimes I have to wait a day.
     
  3. bdistler

    bdistler Well-Known Member Prime Account

    Messages:
    3,534
    Likes Received:
    196
    Trophy Points:
    63
    -
    x10hosting's free-hosting servers run a combination of the Apache web server and the Varnish cache server
    the cache server maybe why there is a delay before you 'see' the file(s) - after you upload it - or see a new 'post'
    the caching time (delay) S/B about 5 seconds for dynamic content and about 5 minutes for static content - there are posts in this forum about it being longer

    to override [ Varnish cache ] try adding the following line to your [ .htaccess ] file in folder [ public_html ]
    Code:
    Header set Cache-Control "max-age=0, private, no-cache, no-store, must-revalidate"
    AND/OR

    #1.> Sign into your cPanel account at --> [ https://www.x10hosting.com/sso/login ] and open cPanel

    #2.> if you are NOT in the [ cPanel x3 ] theme - click on the "Switch Theme" button at the top on the screen - you can choose between [ x10Hosting Basic ] and [ cPanel-x3 ] themes

    #3.> on cPanel-x3 (not x10hosting Basic) homepage - in the [ Software and Services ] block - click on [ Cachewall ] - then set it to [ off ] for each domain
    ###

    the current 'cache' (if any) will need to time-out before this setting becomes effective

    You can also check at [ http://isvarnishworking.com ] to see if the .htaccess modification is working. It should say "Yes! Sort of." and then you should see the Cache-Control header underneath

    NOTE: you might have a 'cache' in your browser and/or ISP

    see --> [ https://x10hosting.com/support/general/varnish-cache ]
    -
    ###
     
  4. akx10mxa

    akx10mxa New Member

    Messages:
    15
    Likes Received:
    0
    Trophy Points:
    1
    Not sure if this was the solution but I did the .htaccess thing then got the above reply and cleared my cache in my chrome browser and it's working, yet I didn't clear Firefox and it's working. So I guess .htaccess did the work? Anyway it's working. If I see a lag in my web page loading I can always kill the .htaccess file, I had to create it just for this reason.
     

Share This Page