Help please

Discussion in 'Free Hosting' started by graphicb, Jul 31, 2012.

Thread Status:
Not open for further replies.
  1. graphicb

    graphicb New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Well on my ftp client i accidently deleted the www directive, and now my website doesnt work. i have my files added to public.html but when i go to my website it gives me this message
    http://prntscr.com/czplm
     
  2. mraz

    mraz New Member

    Messages:
    95
    Likes Received:
    3
    Trophy Points:
    0
    don't worry - you're still safe.

    you can recreate the www folder in your home directory and copy the contents of your public_html to it.

    suggest you to do this from cPanel File Manager.
     
  3. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    Clear your browser cache and check your site again.

    Do not re-create www. Do not copy the contents of public_html to it.
     
  4. Skizzerz

    Skizzerz Contributors Staff Member Contributors

    Messages:
    2,929
    Likes Received:
    118
    Trophy Points:
    63
    www is a symlink to public_html, which is impossible for normal users to create. Some support staff have the necessary access needed to restore this (as well as public_html itself if you manage to delete that -- it has custom permissions/ownership which is also impossible to set via cpanel/ftp), and if it is causing your site to not work you should open a support ticket.
     
  5. graphicb

    graphicb New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    I tried this, and it didn't work, any more solutions?
     
  6. descalzo

    descalzo Grim Squeaker Community Support

    Messages:
    9,375
    Likes Received:
    327
    Trophy Points:
    83
    Try adding ?foobar to the end of the URL, since your ISP is probably caching pages.

    I can see your (empty except cgi-bin) main directory.
     
  7. graphicb

    graphicb New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    What do you mean try adding ?foobar
     
  8. Sharky

    Sharky Community Paragon Community Support

    Messages:
    4,397
    Likes Received:
    91
    Trophy Points:
    48
    http://<your website address>/?foobar

    The bit after the ? is a parameter that is interpreted by the web server to do dynamic stuff - the theory is that by adding it, the intermediary node that is caching your connection will treat the request as new and not load it from the cache. At least, that's the theory.

    For the record, I see a page starting with the following, WITHOUT adding anything to the homepage URL:
    [h=2]Welcome to Graphic Battles[/h]Graphic Battles is a way for graphic designers to compete against each other and get classed accordingly. Apart from being a way to compete against other graphic designers, it can also be used as a resource website. Althought the project has just begun and we have a lot more things to work on we are hoping to finish this project quickly and properly. due to having a small team, our working speed isn't fast paced but in the future we intend to keep the website under constant updates till then please be patient and support us.
     
    Last edited: Jul 31, 2012
  9. graphicb

    graphicb New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Worked thank you
     
  10. Sharky

    Sharky Community Paragon Community Support

    Messages:
    4,397
    Likes Received:
    91
    Trophy Points:
    48
Thread Status:
Not open for further replies.

Share This Page