osCommerce stopped working?

Discussion in 'Scripts, 3rd Party Apps, and Programming' started by hose30, Mar 8, 2009.

  1. hose30

    hose30 New Member

    Messages:
    40
    Likes Received:
    0
    Trophy Points:
    0
    Hi,

    I have been having problems with my site for weeks, one which is now resolved was the 500 Internal Srver Error on every page of my osCommerce based site, however since this has been fixed I have been alerted with another problem.
    I have asked about this on the osCommerce forum and I have left the topic open for a week and it has only had one reply which was 'ask your host', PayPal just told me to ask on osCommerce, so I am stuck...

    Basically everything is fine, but when a cusomter clicks on confirm order in the checkout process to be directed to PayPal to pay, instead of it directing to my custom checkout pages on PayPal, it just directs to the PayPal home page.

    I have no idea what the problem could be, maybe one of the files in my directory eg. checkout_(something).php has a problem, but I haven't changed any of them?
    I did change my PayPal password a while back but I am not sure if this could have done it?

    Does it sound like a PayPal problem? Because to be honest I don't think it is a host problem but I am just double checking as it is what I have been told to do.

    Thanks for your time and any help.
     
  2. nuno_18

    nuno_18 New Member

    Messages:
    47
    Likes Received:
    0
    Trophy Points:
    0
    for me work fine....
     
  3. kgrinsteiner

    kgrinsteiner New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    I found this thread as I had the same exact problem with my oscommerce site running the paypal standard module redirecting to the paypal home page rather than the paypal checkout page. . .unfortunately there was not answer, but through some futher investigating, I found the answer and thought I would share!

    My oscommerce site was installed in late 2007, so is an older version. . . my paypal module was using the url of
    Code:
    https://secure.paypal.com/cgi-bin/webscr
    I needed to change this url to
    Code:
    https://www.paypal.com/cgi-bin/webscr
    in my paypal.php file and now it works perfectly.

    Apparently, paypal stopped using the secure.paypal url so it is not properly redirecting.

    Hope this helps someone!!

    Take care,

    Kyla
     

Share This Page