Site_Inacessible JetPack Plugin [xmlrpc.php Blocked]

Discussion in 'Free Hosting' started by hiddenha, Jun 7, 2016.

Thread Status:
Not open for further replies.
  1. hiddenha

    hiddenha New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi,
    I'm currently using x10 Free Hosting to host my site on a custom domain.
    I'm running WordPress & am trying to install the JetPack plugin.
    When activating the JetPack plugin I get this message:

    Your website needs to be publicly accessible to use Jetpack: site_inaccessible

    I did some research and most people are saying to ask the host whether they have placed some security over the xmlrpc.php file - which is needed in order to active the plugin.

    If so, is there a way I could work around this & install the plugin?

    Site: http://eclecticelite.com
     
  2. SierraAR

    SierraAR Community Advocate Community Support

    Messages:
    827
    Likes Received:
    17
    Trophy Points:
    18
    I can confirm the wordpress jetpack plugin is reporting this error:

    I'd wager a guess that either:
    A: Wordpress.com itself is being denied access to the servers via firewall or other block, or
    B: External websites are denied access to files on the servers in general.

    Either way, this would require someone with a bit more access than I have to confirm the cause of the issue and possibly correct it.
     
    • Like Like x 1
  3. hiddenha

    hiddenha New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Thank you for your response.
    JetPack is an essential plugin for my site to perform the way it needs to.

    I hope we can get this issue resolved or find a workaround to get this plugin working.
     
  4. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    367
    Trophy Points:
    83
    Hi,

    A change has been made that should fix this; please could you try again now? :)

    Thank you,
     
  5. hiddenha

    hiddenha New Member

    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Hi Dead-i
    Thank you for making the change, it is working now.
    Appreciate the help.
     
  6. theteamk

    theteamk Member

    Messages:
    94
    Likes Received:
    1
    Trophy Points:
    8
    I am facing the same issue. I stumbled upon this one. As this is not an old thread, I replied to this one. Please check.

    site: http://androguider.com
     
  7. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    367
    Trophy Points:
    83
    Hi theteamk,

    Please can you confirm that you are definitely seeing the exact error message in this thread, which was a HTTP 403, or is Jetpack reporting a different status code? I can't see any requests making it to Apache to your domain from a certain Automattic IP range, so I'm wondering if there's something else interfering here.

    Thank you,
     
  8. theteamk

    theteamk Member

    Messages:
    94
    Likes Received:
    1
    Trophy Points:
    8
    Thanks for the reply. Surprisingly, Jetpack sprung to life automatically somehow. I will go and have a look at a few files and logs though. Thanks for your help!
     
Thread Status:
Not open for further replies.

Share This Page