URL file-access is disabled?

Discussion in 'Free Hosting' started by lionheart8, Aug 8, 2007.

Thread Status:
Not open for further replies.
  1. lionheart8

    lionheart8 New Member

    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    0
    Hi,
    I have some problems with content/pages/scripts included causing such error messages in Drupal CMS shown below.

    I contacted the CMS forum and these are some od the responses:

    Another http://support.open-realty.org/showthread.php?t=7073 points in the same direction, where they suggest requesting the web host to enable that function.

    I have not made any changes to file/folder permissions.
    The included pages/scripts can be accessed (ie. not via the php include function) directly with no problem.

    Because of the problem, I have had to disable the corresponding scripts to avoid ugly error messages.

    Any help would be appreciated. :biggrin:
     
    Last edited: Aug 8, 2007
  2. lambada

    lambada New Member

    Messages:
    2,444
    Likes Received:
    0
    Trophy Points:
    0
    URL file access is disabled as it can lead to security exploits.

    There is not much we can do about this other than enabling it which would lead to security problems. As far as i'm aware the default Drupal install works fine on our server (though I may be mistaken). If its an addon / MOD for Drupal then perhaps you could find an alternative to it?

    If anyone else has a workaround then perhaps we could discuss it.
     
  3. lionheart8

    lionheart8 New Member

    Messages:
    177
    Likes Received:
    0
    Trophy Points:
    0
    Ok ... Thanks for responding.

    I found a work around ... that is working for me after considering

    ... and the fact, that the required scripts are local.

    Previously I was using the whole url ie:

    I decided to do away with http:// & used the relative path - & all previously affected files worked. :cool:

     
    Last edited: Aug 8, 2007
  4. lambada

    lambada New Member

    Messages:
    2,444
    Likes Received:
    0
    Trophy Points:
    0
    Glad to see its solved.

    :lockd:
     
Thread Status:
Not open for further replies.

Share This Page