x10hosting compatability with dreamweaver CS3?

Discussion in 'Scripts, 3rd Party Apps, and Programming' started by alpha136000, Apr 16, 2008.

Thread Status:
Not open for further replies.
  1. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    yea ok i see that but i still dont get about the directory thing for dreamweaver...... for E.G if my index.html file is in
    C:\Documents and Settings\kevin\My Documents\kevin

    Do i type that in for it?
     
  2. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    I am not entirely sure what you mean but here is an attempt. ;)

    There are two copies of that file, one on your computer in that folder you said, and one on the remote x10hosting server, you should be able to edit the local file on your computer within dreamweaver, and use dreamweaver to upload it back to the remote x10hosting server. Then you can view the file on the web at your x10hosting domain name, which wil be something like

    "www.example.x10hosting.com/(filename)"
    eg. for index.html
    "www.example.x10hosting.com/index.html" or just "www.example.x10hosting.com".
     
  3. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    yea www.alphakevin.exofire.net is pathetic atm lol :O

    But i will type in the url for my index.html right now in dreamweaver.
    Edit:
    [​IMG]

    this is my error when i press test connection....
     
    Last edited: Apr 18, 2008
  4. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    Ah, okay well thats easy to fix.

    The field that you are putting that file location into is actually meant to be left blank, it says 'on the server' so its refering to the remote x10hosting server, and if you set up your ftp username correctly then it will already have the correct folder.

    When dreamweaver does ask you for your 'sites' local folder on your computer then you will need to put in that folder (without the filename by the way, because dreamweaver will look at all the files in that folder).
     
  5. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    Last edited: Apr 18, 2008
  6. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    Check that the ftp account that you made in cpanel has the correct directory ("/public_html"), and make sure that you are uploading the file before you try to view it.

    You should be able to see a list of the files in the remote website in dreamweaver if you are connected, this should help you to work out if you are viewing the correct directory, if you aren't then you can change it, by editing that field which you were using in the screenshot.

    The remote site file viewer within dreamweaver should show folders such as "_private" and "cgi-bin", if it shows "public_html", then you have set the directory to the wrong spot.
     
    Last edited: Apr 18, 2008
  7. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    aaah i see i just had too edit the index.html i downloaded with dreamweaver... then save it.
    Edit:
    hmm it didnt work www.alphakevin.exofire.net is still just ads. perhaps i did the stuff on dreamweaver wrong this is how i inserted my files into www.alphakevin.exofire.net

    I opened my index.html file i downloaded with dreamweaver edited it too my likings (E.G typed in heading etc).
    Then I pressed Site on the menu bar then put.
    I waited for it too load and it asked me about this stuff i forgot -.- i pressed yes and i ticked dont display this message again and waited.
    when it was done loading i checked the website still just plain ads...
    This was all according to the guide i posted on my first post to start this thread :(
     
    Last edited: Apr 18, 2008
  8. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    Check in cpanel to see if you ftp account has the correct directory ("/public_html"), if it doesn't then you will need to change it, so that you are uploading straight to the correct location. Otherwise you could be putting that file into another folder which may not be shown online.
     
  9. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    [​IMG]

    errrm... so how do i edit it?
     
  10. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    The short and anouying anwser is that you can't,

    If you are using the 'alpha136000@alphakevin.exofire.net' account in dreamweaver, then you will need to delete it and create a new ftp user with the same username and password, but with the directroy as 'public_html', when it prompts you and ask if you want to delete the files that belonged to that account just say no.

    If you are using the alpha136 account then you can go into dreamweaver and edit the site's options, that field which said 'what folder on the server do you want to store you files on?' should be changed to 'public_html'.
     
  11. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    well if u look at my screenshot before i was using alpha136 and i dont really understand what you mean... but

    do you think i should edit my account that i used and use alpha136000@exofire.net instead of alpha136?
     
  12. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    Yeah okay, I didn't see that before. You can easily keep using the same username which was 'alpha136'.

    All you need to do is open up dreamweaver, go to the settings for the site, under the site tab. You will need to find the field/setting which is called something like, 'folder on remote server' or 'what folder on the server do you want to store you files on?', remember that I told you to leave it blank? Well because of the ftp user you are using you should now change it to 'public_html', and then you can upload files to the correct folder and you should be able to view them properly on your domain.
     
    Last edited: Apr 18, 2008
  13. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    nah still not working :(
     
  14. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    Okay, have a look at what is being shown in the remote site area/folder for dreamweaver, you can use it to work out where you are within the remote server's website. If you can see a folder called 'public_html', then put your files into there.

    Otherwise I can't see what could be wrong.
     
  15. alpha136000

    alpha136000 New Member

    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    0
    gosh i edited the index.html in my folder and its still just ads.....
    Edit:
    here is a coincidence...

    [​IMG]


    see the thing i circled with red?
    when i clicked allow on it, it comes up with ads.
     
    Last edited: Apr 19, 2008
  16. Zenax

    Zenax Active Member

    Messages:
    1,377
    Likes Received:
    4
    Trophy Points:
    38
    First things first. The thing you circled in red is a security feature within IE 7 to stop certain scripts from running. You can ignore this.

    Open dreamweaver up.

    Choose the manage sites option from the sites menu.

    [​IMG]

    This box should appear:

    [​IMG]

    Select the site. Now press the edit button and the following window will appear. Make sure you are under the advanced tab.
    [​IMG]

    Set the access to FTP.

    Set the ftp host to your website domain but instead of http:// change it to ftp.

    Set the host directory to www

    Set the login to your cPanel username.

    Set the password to your cPanel password.

    Tick the first two boxes at the bottom of the box. This means that everytime you save a file within dreamweaver it will automatically load the changes up to your site.

    Now click on Testing server on the left hand side under category.

    [​IMG]

    Add the same settings. The server model should be PHP MySQL and the access should be FTP.

    Set the same properties in the first box.

    To test they work on both press the test button. You should get this box appear:

    [​IMG]


    It should now work. Post back with any problems you have! Now you can just open up any html files you have, save them and it will upload them to your directory. have fun!

    Peace
     
    Last edited: Apr 19, 2008
  17. LHVWB

    LHVWB New Member

    Messages:
    1,308
    Likes Received:
    0
    Trophy Points:
    0
    This issue seems to be resolved, if the author has any questions about this issue then they can reopen this thread.

    * Closed *
     
Thread Status:
Not open for further replies.

Share This Page