503 Service Unavailable

Status
Not open for further replies.

awaymiss

New Member
Messages
21
Reaction score
0
Points
1
I've been receiving an 503 Service Unavailable error on my Wordpress blog for at least a day. I looked on the Resource Usage panel in cPanel which said my site has been limited within the last 24 hours. I'm not really sure what that means, but after researching, I saw there were other people having this issue and that it was a plugin with caching capabilities or some such. I wasn't sure which plugin it was doing this, so I manually removed all of the plugins that may be caching or scanning my blog. My question is, how do I get rid of this error message? Will my site refresh after so many hours or does the host have to fix it for me? My site is: http://lizzysgrandadventure.x10.mx/ Thank you for your time.
 

grupocvr

New Member
Messages
2
Reaction score
0
Points
1
Since yesterday, I have the same problem too with erp.x10host.com

I would like to know how many time should we wait since Resource Usage is limited or if I have to do any change / update / process to fix it.

Thank you and best regards.
 

chatngox

Member
Messages
122
Reaction score
3
Points
18
What caching plugin you are talking about? If you have one I recommended to remove the plugin and use the one provided by x10 instead.
Recently x10 made changes to htaccess file configuration, some code is not allowed which might result in this. do a backup of your htaccess code before you modify the code. Go read
Important Changes to Apache directives and options supported in .htaccess files
 

Dead-i

x10Hosting Support Ninja
Community Support
Messages
6,084
Reaction score
367
Points
83
Hi,

@awaymiss All of your PHP scripts and directories have permission levels of 777, which is a big security risk, which is why the web server is showing the 503 error. Please fix your file permissions; files should be 644, and directories should be 755. You can change file permissions from your cPanel File Manager (select files, and click the Change Permissions icon at the top), or through FTP.

@grupocvr It's the same situation for you, but only your index.php file is set to 777. Please change it to 644.

Thank you,
 

awaymiss

New Member
Messages
21
Reaction score
0
Points
1
@Dead-i That was it! Thank you! And it also explains why Wordfence plugin was showing people trying to access some of the files on my blog like the admin.php and stuff. I had been just blocking them from accessing my blog. Thank you for explaining this about file permissions. I had just let the server choose when I installed them. Hopefully, this makes my blog more secure and better to block my harassers.

@chatngox I said I didn't know what plugin it was and that my googling on the error returned that it was a caching plugin causing the problem. js Either way, problem solved. It was the file permissions.

Thank you. :)
 
Status
Not open for further replies.
Top