Attn Corey - ASP.NET .NET2.0 framework still not working

Status
Not open for further replies.

Reaperman

New Member
Messages
16
Reaction score
0
Points
0
My previous post\thread was closed without being resolved.....dunno why. My last two updates to it went unanswered.

http://forums.x10hosting.com/free-hosting/34210-attn-corey-enabling-asp-net-net-2-0-framework.html

Anyway it's been like a week and I still am unable to develop on my site because ASP.NET and/or the .NET 2.0 framework isn't working on your server....

Error message is
Service Temporarily Unavailable

The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later. Apache/1.3.39 Server at xb.x10hosting.com Port 80

I know it's a false error as the index.html pages still work fine. Any idea what's causing it?
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Kind of; The problem is I haven't had any free time to work on it, ASP is just not meant to work with Linux and is even harder to get it working with multiple sites. I am looking into a solution that might work which involves passing all ASP requests to a separate server running on port 8080. Hopefully I can get this working soon.
 

Slothie

New Member
Messages
1,430
Reaction score
0
Points
0
I think you mentioned you were running mod_mono previously... What happened to it?

I'm pretty sure it works with shared hosting as I've managed to set it up in a small box for a client of mine. Let me know if you need help and I'll try to chip in my 2 bits.
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
I set mod_mono up but it seems the only way to get it to work is to start the asp server bit for each user, which would end up causing a huge problem since we have so many users.

Right now the procedure for mod_mono that I'm doing is editing the VirtualHost, starting a new SSH session with screen, starting the ASP server, then disconnecting the screen session.

What I'm trying to do is make the single server work for ALL virtualhosts, which I wasn't successful at yet.
 

Slothie

New Member
Messages
1,430
Reaction score
0
Points
0
Wait, you're launching multiple mono servers for each site that requests it?
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Each virtual host ;( I tried launching one mono server to cover /home but it didn't seem to work as Reaper is still getting errors above.
 

Slothie

New Member
Messages
1,430
Reaction score
0
Points
0
Which version of mono are you running?

I'm assuming you have mod_mono, xsp and mono base installed. I manged to set it up running on a production box (albeit small one) with only one mono running.
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Does it run across all the virtual hosts on yours?

I'm using the cPanel based version which might be the mistake. If I use something else I've learned from the past to set aside 3+ hours to deal with the issues of changing anything that cPanel handles.
 

Slothie

New Member
Messages
1,430
Reaction score
0
Points
0
Yes, it runs perfectly across all virtual hosts with only 1 instance of mono
 

Reaperman

New Member
Messages
16
Reaction score
0
Points
0
Kind of; The problem is I haven't had any free time to work on it, ASP is just not meant to work with Linux and is even harder to get it working with multiple sites. I am looking into a solution that might work which involves passing all ASP requests to a separate server running on port 8080. Hopefully I can get this working soon.

Thanks for looking into it...I appreciate the effort you're making to get it running. I'll settle back and be patient while you work it out....when my thread was closed I was just concerned that you hadn't seen my previous replies.
 

Reaperman

New Member
Messages
16
Reaction score
0
Points
0
Any progress?.....My default.aspx page is back to displaying the source instead of the previous error "Service Temporarily Unavailable"
 

dfrench

New Member
Messages
4
Reaction score
0
Points
0
I noticed brandon replied to a thread about ASP.Net availability yesterday asking the gentleman to creating a new thread. I hope they have it completed. I would be happy with Net 1.1 support myself. Lets keep our fingers crossed and hope it is ready..
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
I need some ad-free people to help me test this out on our new server. Please PM me if you volunteer
 
Status
Not open for further replies.
Top