e107 installlation

Status
Not open for further replies.

Shade

New Member
Messages
154
Reaction score
0
Points
0
Hi,

I have been trying to install e107 after deciding to change my CMS. However, i have problems running the install.php - the problem is from x10hosting where the server doesnt like particular php script running.

Wondering if its possible to do something about it so I/you can install e107 for me.

Domain: shadowgaming.co.uk

File permissions should be set correctly.
 

Torch

New Member
Messages
634
Reaction score
0
Points
0
Well, from what I learened this host doesn't allow 777 on PHP which are executed directly on browsers call. So your best bet is to use some FTP program which can change CHMOD on all files in your e107 directory (like SmartFTP 2) and change it to 755.

If that is not the problem, please explain the error you're getting in more detail.
 
Last edited:

Vyriix

New Member
Messages
126
Reaction score
0
Points
0
the probelm is x10hosting is setup abit differently, and buffer will not work. check my signature for steps to install it on x10hosting.
 

Shade

New Member
Messages
154
Reaction score
0
Points
0
Yes i have tried both your written tutorial and your binary of the new 0.7.4 with little success. I have no yet tried 0.7.2 but surely x10hosting admins - you could either:

1) Put it in cpanels autoinstall program (forget what its called but it can install phpnuke etc)

or

2) Just allow e107 to do whatever it is e107 needs to do to be installed.

I will try 755 to see what happens but i am getting sick of uploading the damn thing as the extractor only half extracts the e107 contents in the folder
 

Vyriix

New Member
Messages
126
Reaction score
0
Points
0
you have to follow the tutorial, when i mean 0.7.2 installer, i really meant it, 0.7.4 is a different installer, and you have to find your own fix.

On a side note, you don't even need to give 777 permission for any files on e107, highest u need to give is 775, which is compatible on x10hosting.
 
Last edited:

jensen

Active Member
Messages
1,166
Reaction score
21
Points
38
The e107 installation is not so straight forward. You need to change the file permission and then change it back after the installation. Would be difficult for x10 to "just let e107 do what is has to" because security would be a problem for every user.

Also you need to add the x10ads on every page. That was a tough one until I learnt PHP.

Chris S has kindly modded some installer to have the x10 ads if you need them but e107 is not yet on the list when I checked it 49 seconds ago
http://forums.x10hosting.com/showthread.php?t=16058
 

Vyriix

New Member
Messages
126
Reaction score
0
Points
0
jensen said:
The e107 installation is not so straight forward. You need to change the file permission and then change it back after the installation. Would be difficult for x10 to "just let e107 do what is has to" because security would be a problem for every user.

Also you need to add the x10ads on every page. That was a tough one until I learnt PHP.

Chris S has kindly modded some installer to have the x10 ads if you need them but e107 is not yet on the list when I checked it 49 seconds ago
http://forums.x10hosting.com/showthread.php?t=16058

Are you sure placing an ads is that hard on e107? It just takes me 1 minute to get it up perfectly. and also, I have already posted my ads included e107 pack inside that thread, which was few days ago.

Guess you did not read the thread clearly.
 
Last edited:

jensen

Active Member
Messages
1,166
Reaction score
21
Points
38
Yep, it was that hard because I didn't get the codes to show up properly. I could just give a text link to x10 but not insert the code requested. Searched the forums and not much help. Maybe because you weren't here yet, to help me out. :D (This was during the e107 0.5 version) WOW you only used 1 minute.

When I learnt PHP, I just edited the index file and "tada" the ads were on everypage as required. Then I switched to WordPress. :)

Edit: hmm.. visited your site, very nice but don't see the x10 ads.
(or maybe the x10corporate ad has tied up with yahoo ads)
 
Last edited:

Shade

New Member
Messages
154
Reaction score
0
Points
0
On a side note, you don't even need to give 777 permission for any files on e107, highest u need to give is 775, which is compatible on x10hosting.

Well, I have tried with 775 but its bleming annoying how I cant get it to show up with anything. I keep uploading and nothing. Changign with file permissions and nothing. Tried using your messed around version - nothing.

Im beginning to get flustered with it all. Wheres an admin to have a look at this when you in need of one.

If security is an issue a script of installing e107 to allow certain permissions would be nice.
 

Vyriix

New Member
Messages
126
Reaction score
0
Points
0
you dont need to change the file permissions if you just get the 0.7.2 gz file and extract it on the server. then follow the steps and replace the files that are need to be fix. You dont even need to modify any file permissions, all you need is just follow the guide I wrote
 
Status
Not open for further replies.
Top