Email not working

Status
Not open for further replies.

ghardin

Member
Messages
74
Reaction score
0
Points
6
I have set up an email account
I can send email from any account TO that address and it is received a few seconds after being sent. A reply to that email never arrives at ANY address.

I have tried several clients, including webmail, Outlook, Outlook Express, Gmail.
There are no messages stuck in any spam filters.

Website is Joomla 3.4. I have tried PHP mail - Joomal says email sent but nothing ever is delivered
I tried SENDMAIL, nothing get delivered.
Tried using SMTP with Gmail SMTP setting from Gmail with SSL and authentication both off and on and SMTP always fails.

This website is for a neighborhood watch program to report vandalism and gang activities and email contacts and registration emails is VERY important. I need this working! I have X10 premium account as well and no such problem exists there.

Anyone have any suggestions? email address setup on the host for more than 36 hours now.
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Our outbound email servers are much more strict on allowing email for free hosting due to the high levels of abuse.

If you can let me know an email address you're sending to that is not receiving the email I can look it up and see why it didn't make it out and offer some suggestions on things you can change.
 

ghardin

Member
Messages
74
Reaction score
0
Points
6
Our outbound email servers are much more strict on allowing email for free hosting due to the high levels of abuse.

If you can let me know an email address you're sending to that is not receiving the email I can look it up and see why it didn't make it out and offer some suggestions on things you can change.
==========================
gr*****@comcast.net
gh******26@gmail.com (took about 12 hours for the mail to go thru)
admin@h*******rei.com (My premium account on X10) still has not delivered
gh**3**@gmail.com (has not delivered)
gh******6@comcast.net (has not delivered)

If this is going to be a continuing problem then I may have to use some other host for this-this site is a non profit neighborhood watch group and there is no money to pay for premium hosting. But we NEED emails to work. Even if I have to use some sort of SMTP setup in Joomla. But does not seem to work at all here. (I can use SMTP with Joomla when setup on a local machine, so I know that is not a Joomla issue)
 
Last edited by a moderator:

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
External SMTP is disabled so that all outgoing mail can be scanned. One of the problems with free hosting is that, since there is no cost to doing so, a lot of people try to use the hosting for abusive/illegal purposes; that has historically led to blacklisting that affects everybody, so the criteria for outgoing mail are fairly strict (though not egregiously so) - generally speaking, if you have a subject (mandatory) and real text content that isn't typical of spam, phishing or 419-type fraud, it'll get through. "Testing" probably won't.
 

ghardin

Member
Messages
74
Reaction score
0
Points
6
External SMTP is disabled so that all outgoing mail can be scanned. One of the problems with free hosting is that, since there is no cost to doing so, a lot of people try to use the hosting for abusive/illegal purposes; that has historically led to blacklisting that affects everybody, so the criteria for outgoing mail are fairly strict (though not egregiously so) - generally speaking, if you have a subject (mandatory) and real text content that isn't typical of spam, phishing or 419-type fraud, it'll get through. "Testing" probably won't.
===========================================
I totally understand the need to control the spam email from free hosting like this. I despise spam of any sort and those that propagate it. But our need is primarily to be able to send the emails for user authentication when a user registers and if I cannot verify that that is working then the site is crippled. It is those signup emails that are not getting through that I am concerned about. I can send email from the webmail client with a very benign subject and message and it still never arrives.
I went to MXToolbox .com and put in the x10host.com on the blacklist check and it came back clear on all but one list, so having isp's blocking the domain seems unlikely. The admin email account for the site is receiving email just fine, but cannot deliver any outbound and that is not acceptable.
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Can you try sending now? I've made some modifications specific to your emails.

I did find some test ones, unfortunately I can't do anything about those but if you send registration\confirmation\normal emails they should go through fine now.
 

ghardin

Member
Messages
74
Reaction score
0
Points
6
Can you try sending now? I've made some modifications specific to your emails.

I did find some test ones, unfortunately I can't do anything about those but if you send registration\confirmation\normal emails they should go through fine now.
==================
That works. Thanks Corey! Any idea what the problem was?
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
I did some training using your emails with the spam filters. It was scoring them a bit too high even considering the heightened sensitivity we have set for them.
 

certifix

New Member
Messages
4
Reaction score
0
Points
1
I'm having the same problem. I have a form object on my webpage and have set up the email address. The form says it sent without error but i never receive it in my inbox. I am able to send from my gmail to that email but when i try and reply i never get it in my gmail inbox and its not in spam. certifix.pcriot.com is my domain and Tom@certifix.pcriot.com is my hosted email address. Can someone please help me?
 

jbrennec51

New Member
Messages
29
Reaction score
0
Points
1
Ya know x10 used to allow smtp to an external mail servers, ie gmail.
Google has many security levels that have to be completed for mail to be severed via x10.
why not move the problem from x10's plate to Google's?
 
Status
Not open for further replies.
Top