Error 500 when trying to load home page

Status
Not open for further replies.

falzueta

New Member
Messages
4
Reaction score
0
Points
0
My domain mercadofierros.co.cc isn't working for a week now. When a try to load any page in my browser, I've got the following error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@mercadofierros.co.cc and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


:dunno:

Did I do something wrong? Any help would be highly appreciated.
Thank you very much.
Regards

-----------------------------------------------------------------------------------------------------------------

EDITED:

I've found the following error in cpanel error log list:

"[Thu Nov 05 08:18:54 2009] [alert] [client 200.43.32.9] /home/falzueta/public_html/.htaccess: RewriteCond: bad flag delimiters]"

Despite it says it is an htaccess error I 'm thinking it's related to changes I've done in some .css files, I'll check it again then I'll tell you.
Thank everyone for your responses.

----------------------------------------------------------------------------------------------------------------------------

LAST EDITION:


:D SOLVED!!!!!!


Thanks for your hints!!!!!


I commented everything (put # in every line) in .htaccess (like it was empty), and the site began to work again!

Thank you all for your responses, this is one of the most helpful communities around free webhostings.
 
Last edited:

dpilmore

New Member
Messages
109
Reaction score
1
Points
0
Clear your web Cache mate, thats all i can think of anyway.
also what is your site address, i will see if i can connect.
 

computerkids

New Member
Messages
54
Reaction score
2
Points
0
I had the same problem I was using eset antivirus and for some reason it would not allow a connection when using front page. It did however allow filezilla to upload. i dont really like having to use filezilla so i uninstalled the antivirus program.hope this helps it took me a week to figure it out.
 

midnighthearts

New Member
Messages
18
Reaction score
0
Points
0
Most probable there is an infinite loop in your script. The loop can be a malpractice in the code. Or related to the variables that aren't identical though supposed to be such. For example recently has been a time shift. If two systems report two different times then here we are - the script opens and immediately closes something on timeout all the time in a loop.

see also MySQL and Apache
 

garrettroyce

Community Support
Community Support
Messages
5,603
Reaction score
244
Points
63
There is likely an error in a .htaccess file, if you are using one.

Clear your web Cache mate, thats all i can think of anyway.
also what is your site address, i will see if i can connect.

This often helps many problems, but I also see the error, so it looks like a server side issue and not client side.
 
Last edited:

adamparkzer

On Extended Leave
Messages
3,745
Reaction score
81
Points
0
My domain mercadofierros.co.cc isn't working for a week now. When a try to load any page in my browser, I've got the following error message:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator, webmaster@mercadofierros.co.cc and inform them of the time the error occurred, and anything you might have done that may have caused the error.
More information about this error may be available in the server error log.
Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

:dunno:

Did I do something wrong? Any help would be highly appreciated.
Thank you very much.
Regards

What were the most recent changes you made to your website?

What is your website programmed in? Are you using someone else's software, such as MyBB or Wordpress?

Could you copy and paste the contents of your .htaccess file here?
 

garrettroyce

Community Support
Community Support
Messages
5,603
Reaction score
244
Points
63
Most probable there is an infinite loop in your script. The loop can be a malpractice in the code. Or related to the variables that aren't identical though supposed to be such. For example recently has been a time shift. If two systems report two different times then here we are - the script opens and immediately closes something on timeout all the time in a loop.

see also MySQL and Apache

Infinite loops usually end in a timeout or failure to allocate memory, but it is possible I suppose. I'm not sure about the time thing though, that's an interesting thought.
 

midnighthearts

New Member
Messages
18
Reaction score
0
Points
0
well, at least I found this in my code and could replicate the error. I also think that the recent splash of closed accounts because of intensive use of resources is due to this fact. The looping requires thousand times more resources than usual process.
 
Last edited:

falzueta

New Member
Messages
4
Reaction score
0
Points
0
Clear your web Cache mate, thats all i can think of anyway.
also what is your site address, i will see if i can connect.

Thank for your response! Could you tell me how to do it? (I`m a little newbie ;))
Edit:
What were the most recent changes you made to your website?

What is your website programmed in? Are you using someone else's software, such as MyBB or Wordpress?

Could you copy and paste the contents of your .htaccess file here?

Thanks for your response!
Yes I'm using wordpress right now.
This is my htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.order de</IfModulden
# END WordPress
t>
AuthName mercadofierros.co.cc
AuthUserFile /home/falzueta/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/falzueta/public_html/_vti_pvt/service.grp

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


Is there something wrong?

My recent changes were into .css files containing part of the layout of the homepage.

Thank you very much!
 
Last edited:

dpilmore

New Member
Messages
109
Reaction score
1
Points
0
well by the sound of some comments made mate, you dont need to clear your cache.
 

falzueta

New Member
Messages
4
Reaction score
0
Points
0
What were the most recent changes you made to your website?

What is your website programmed in? Are you using someone else's software, such as MyBB or Wordpress?

Could you copy and paste the contents of your .htaccess file here?


:biggrin: SOLVED!!!!!!


Thanks for your hints!!!!!


I commented everything (put # in every line) in .htaccess (like it was empty), and the site began to work again!

Thank you all for your responses, this is one of the most helpful communities around free webhostings.
 

garrettroyce

Community Support
Community Support
Messages
5,603
Reaction score
244
Points
63
Some of the .htaccess may have been important. Perhaps you could post it's contents here so we can find the problem. Or you could re-enable one line at a time until you find the problem line and post it here. It's probably a php_value line that's the problem
 

misson

Community Paragon
Community Support
Messages
2,572
Reaction score
72
Points
48
RewriteRule . /index.order de</IfModulden
# END WordPress
t>
Well, that doesn't look right. Should be something like:
Code:
    RewriteRule . /index.order
# where does this go: de ?
</IfModule>
# END WordPress
See the RewriteRule documentation for the full syntax. The first set of lines marked as being for Wordpress also looks like duplicates of the second set; you can delete everything from the first "# BEGIN WordPress" through the "t>" line.

Doesn't look like it would cause an error in one of the RewriteCond lines, however.
 
Last edited:

falzueta

New Member
Messages
4
Reaction score
0
Points
0
well by the sound of some comments made mate, you dont need to clear your cache.
:biggrin: You're right, thanks anyway! see you next issue... ;)
Edit:
Some of the .htaccess may have been important. Perhaps you could post it's contents here so we can find the problem. Or you could re-enable one line at a time until you find the problem line and post it here. It's probably a php_value line that's the problem


This is my .htaccess file:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.order de</IfModulden
# END WordPress
t>
AuthName mercadofierros.co.cc
AuthUserFile /home/falzueta/public_html/_vti_pvt/service.pwd
AuthGroupFile /home/falzueta/public_html/_vti_pvt/service.grp

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress


Instead of comment everything, in order to isolate problem, I'll try change what MISSON sugested, there must be the issue I think...
 
Last edited:
Status
Not open for further replies.
Top