Forum is very slow at times

george21

X10Hosting Fanatic
Prime Account
Messages
114
Reaction score
1
Points
18
I find it near impossible to help people on the forum sometimes since it's very slow. I just did a Pingdom test on the forum and the result was 7 seconds. http://tools.pingdom.com/fpt/#!/bqlydHnO1/x10hosting.com/forums

T
he ping was bad as well:
C:\Users\george>ping x10hosting.com

Pinging x10hosting.com [99.198.123.240] with 32 bytes of data:
Reply from 99.198.123.240: bytes=32 time=145ms TTL=50
Reply from 99.198.123.240: bytes=32 time=237ms TTL=50
Reply from 99.198.123.240: bytes=32 time=209ms TTL=50
Reply from 99.198.123.240: bytes=32 time=131ms TTL=50


Ping statistics for 99.198.123.240:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 131ms, Maximum = 237ms, Average = 180ms


I would get a lot more posts in and help people if the website is faster. I understand a lot of effort has been put in on client servers, however the x10hosting main website is more important, since if that's slow, what are clients going to think?

It might just be a case of optimization rather than a hardware upgrade or DC issue.

Thanks.
 

Smith6612

I ate all of the x10Pizza
Community Support
Messages
6,518
Reaction score
48
Points
48
Not seeing a performance issue on my end with the forums. Seems rather quick to me. Sometimes the forums do hang, and who knows why that is. Database maintenance by the software or the web server getting slammed all at once? Who knows..
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
That's a very sporadic ping... the forums will be updated soon, maybe that will fix it. vB has seemed to get slower over time for us even with better hardware... it's all running on SSDs with all kinds of caching.
 

george21

X10Hosting Fanatic
Prime Account
Messages
114
Reaction score
1
Points
18
I see. I'm not too sure updating the version of VB will help. Just looking through the changelog, there's nothing mentioned about performance improvements. vBulletin has never been the fastest forum software. Might be worth moving to MyBB or possibly XenForo.
 

Skizzerz

Contributors
Staff member
Contributors
Messages
2,929
Reaction score
118
Points
63
We have nearly one million posts and members, with around 200,000 threads. In addition to the large size of the forum, we have a custom theme and other backend modifications made to the forums to integrate it with our hosting systems (and similar custom software written that interacts explicitly with vBulletin to grab forum information, which would need to be modified). While migrating to a different forum software would be possible, it would be very time-consuming and in my opinion not worth the effort and headaches such a large-scale migration would cause, at least not at this time.

That being said, I do hate vBulletin with the fury of a thousand suns...
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
I did a good amount of work on the forum database, is it running any better for you?
 

george21

X10Hosting Fanatic
Prime Account
Messages
114
Reaction score
1
Points
18
I did a good amount of work on the forum database, is it running any better for you?

It seems fine at the moment. The ping has reduced by around 60 miliseconds too, which is good.

C:\Users\george>ping x10hosting.com

Pinging x10hosting.com [99.198.123.240] with 32 bytes of data:
Reply from 99.198.123.240: bytes=32 time=125ms TTL=50
Reply from 99.198.123.240: bytes=32 time=125ms TTL=50
Reply from 99.198.123.240: bytes=32 time=124ms TTL=50
Reply from 99.198.123.240: bytes=32 time=124ms TTL=50

Ping statistics for 99.198.123.240:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 124ms, Maximum = 125ms, Average = 124ms
 
Top