Getting 500 internal server error from 2 days

Status
Not open for further replies.

gauravs9085

New Member
Messages
17
Reaction score
0
Points
0
I'm able to open my root site successfully but if i click on any link in it then 500 internal server error comes up. It's comming from two days now.
Pls look into it
 

vishal

-::-X10 Guru-::-
Community Support
Messages
5,255
Reaction score
192
Points
63
Check the permission of the folders and files.It should be 755 and not 777
 
Last edited:

gauravs9085

New Member
Messages
17
Reaction score
0
Points
0
In root directory my folders have 755 permission and files have 644 permission, is it right? or i have to set file permission to 755 too
 

Gouri

Community Paragon
Community Support
Messages
4,564
Reaction score
245
Points
63
In root directory my folders have 755 permission and files have 644 permission, is it right? or i have to set file permission to 755 too

The public_html required to have 750

And inside files and folders can be 644 or 755 what ever you have.
 
Last edited:

Anna

I am just me
Staff member
Messages
11,524
Reaction score
556
Points
113
Your site works fine for me, is this still an issue?
 

gauravs9085

New Member
Messages
17
Reaction score
0
Points
0
^^ My site is working fine but if you click any link in it you will get 500 internal server error.
I'm using joomla
500 internal server error started occuring when i changed the following settings in joomla global configuration

  1. enbled SEF urls in SEO settings
  2. enabled Apache mod_rewrite in SEO settings
Here is my .htaccess file provided by joomla
Code:
 ##
# @version $Id: htaccess.txt 14401 2010-01-26 14:10:00Z louis $
# @package Joomla
# @copyright Copyright (C) 2005 - 2010 Open Source Matters. All rights reserved.
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Joomla! is Free Software
##


#####################################################
#  READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations.  It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file.  If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's.  If they work,
# it has been set by your server administrator and you do not need it set here.
#
#####################################################

##  Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

#
#  mod_rewrite in use

RewriteEngine On

########## Begin - Rewrite rules to block out some common exploits
## If you experience problems on your site block out the operations listed below
## This attempts to block the most common type of exploit `attempts` to Joomla!
#
## Deny access to extension xml files (uncomment out to activate)
#<Files ~ "\.xml$">
#Order allow,deny
#Deny from all
#Satisfy all
#</Files>
## End of deny access to extension xml files
RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|\%3D) [OR]
# Block out any script trying to base64_encode crap to send via URL
RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [OR]
# Block out any script that includes a <script> tag in URL
RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Send all blocked request to homepage with 403 Forbidden error!
RewriteRule ^(.*)$ index.php [F,L]
#
########## End - Rewrite rules to block out some common exploits

#  Uncomment following line if your webserver's URL
#  is not directly related to physical file paths.
#  Update Your Joomla! Directory (just / for root)

# RewriteBase /


########## Begin - Joomla! core SEF Section
#
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !^/index.php
RewriteCond %{REQUEST_URI} (/|\.php|\.html|\.htm|\.feed|\.pdf|\.raw|/[^.]*)$  [NC]
RewriteRule (.*) index.php
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization},L]
#
########## End - Joomla! core SEF Section
I also get 500 internal server error when trying to backup my site with akeeba backup.

In my opinion Boru server is still not stable.
 
Last edited:

Anna

I am just me
Staff member
Messages
11,524
Reaction score
556
Points
113
Hello,

Can you check now, I changed one thing in your .htaccess file.
What I did was enable RewriteBase /

The need to do so was introduced a couple months backs when we changed how web requests were handled.
 

Zubair

Community Leader
Community Support
Messages
8,766
Reaction score
305
Points
83
Since Your problem is resolved Now. I am going to close this thread to mark it as resolved. Feel free to create a new thread if you need more help.

***Thread Closed***
 
Status
Not open for further replies.
Top