mail() function not working - unable to create views in mysql DB

Status
Not open for further replies.

chary70

New Member
Messages
5
Reaction score
0
Points
0
Hello,

Here are the list of problems which Im facing , please look into them.

  • The mail() function is not working in my account.
  • There is no permission to create VIEWS in mysql Database.

Account details
cpanel username : chary
subdomain : www.sandeepchary.exofire.net
Hosting package : adfree - adfree


Please help me as soon as possible

Thanks in Advance ;)
 
Last edited:

adamparkzer

On Extended Leave
Messages
3,745
Reaction score
81
Points
0
The mail() function is not enabled or disabled on an account-to-account basis; it is available for everyone using x10Hosting. Did you check your code to see if you are using the mail() function properly?
 

chary70

New Member
Messages
5
Reaction score
0
Points
0
The mail() function is not enabled or disabled on an account-to-account basis; it is available for everyone using x10Hosting.

Ok ...I dint knew that..... thank you :)

but the problem is that the script containing mail() function was working fine 20 days back .... but the same script is not working now.... no changes are made to the script......wht may be the problem?
 

ah-blabla

New Member
Messages
375
Reaction score
7
Points
0
Quite a few people are having mail problems, so I'm not sure what's up.

Regarding the Database problem: make sure you:
1) Create a database in cPanel (as you have probably done)
2) Create a user for the db in cPanel
3) Give that user permissions for the db in cPanel.
 

chary70

New Member
Messages
5
Reaction score
0
Points
0
Yeah ..... I've followed the same procedure while creating the database ..
 

xav0989

Community Public Relation
Community Support
Messages
4,467
Reaction score
95
Points
0
Did you give the user full permission to the database?
 

tregtar

New Member
Messages
79
Reaction score
0
Points
0
I also am experiencing similar mail issues. the db user has full permission on the database. the mail function was working fine up until a couple of weeks ago. perhaps the issues we've been experiencing with mysql and cpanel these last few days are all related?
 

tregtar

New Member
Messages
79
Reaction score
0
Points
0
I am using a program called Webid. For unknown reasons the automated emails this program generated are no longer being sent. This did work fine about 2 weeks ago.
The software is an auction software and emails would be generated when someone registered, or listed and item or won an item and when the item expired, etc...
I recreated the db and re-installed just in case a file became corrupted, but nothing seems to work.
No one else on the support forum for this software was able to replicate the issue so you folks are my last resort.

I am including the php file that controls the emails.

This is such a fabulous piece of software and I'd hate to not be able to use it. Any help would be greatly appreciated.
 

Attachments

  • functions_email.zip
    3.1 KB · Views: 16

descalzo

Grim Squeaker
Community Support
Messages
9,375
Reaction score
327
Points
83
but the problem is that the script containing mail() function was working fine 20 days back .... but the same script is not working now.... no changes are made to the script......wht may be the problem?

A problem seems to arise when the "From" header does not match one of the email accounts for your domain. The script works for awhile, and then the system stops sending the mail.

If you are using a gmail or hotmail account as the "From", try creating an email account in your domain and using that.
 

tregtar

New Member
Messages
79
Reaction score
0
Points
0
A problem seems to arise when the "From" header does not match one of the email accounts for your domain. The script works for awhile, and then the system stops sending the mail.

If you are using a gmail or hotmail account as the "From", try creating an email account in your domain and using that.

Descalzo is right. I created an email account in cPanel and am now using that. Everything is back to normal and working. Thank you!
 

chary70

New Member
Messages
5
Reaction score
0
Points
0
Hey...thanks a lot ..... the mail() function is working perfectly now.

But my problem with creating views still exists.
 
Status
Not open for further replies.
Top