My site is still down

Status
Not open for further replies.

new49ers

New Member
Messages
16
Reaction score
0
Points
1
I have read on other threads that migration is complete and everything is OK.
I have two message forums hosted with X10. One of them has become inaccessible and I don't know how to fix it. Can anyone tell if this problem is a result of the new migration process at X10 or not? The address of my forum is: http://new49ers.x10host.com/

The error message I get is:
General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

I have asked for help on the community forums, but am not understanding the answers I am getting.

Thank you for anything you might be able to supply.
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
I have read on other threads that migration is complete and everything is OK.
I have two message forums hosted with X10. One of them has become inaccessible and I don't know how to fix it. Can anyone tell if this problem is a result of the new migration process at X10 or not? The address of my forum is: http://new49ers.x10host.com/

The error message I get is:
General Error
SQL ERROR [ mysql4 ]

mysql_connect function does not exist, is mysql extension installed? []

An sql error occurred while fetching this page. Please contact an administrator if this problem persists.

I have asked for help on the community forums, but am not understanding the answers I am getting.

Thank you for anything you might be able to supply.
Given the error message I'd say you would need to change php version to 5.6 (mysql_ are depreceted and removed with php 7.0), make sure to check the functions needed, mysql at a minumum.

You'll find the option to switch php version under "Extra Features"
 

new49ers

New Member
Messages
16
Reaction score
0
Points
1
Given the error message I'd say you would need to change php version to 5.6 (mysql_ are depreceted and removed with php 7.0), make sure to check the functions needed, mysql at a minumum.

You'll find the option to switch php version under "Extra Features"

Thank you for your response Anna. The only upgrade options I can find are 5.0.1 But the MyAdmin panel that it shows me seems to be quite old also.
phpMyAdmin 4.9.4
Released 2020-01-08.

Under the heading "Select PHP Version" there is only this one choice:
Current PHP version
native (7.2)
PHP version
native (7.2)


Set as current
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
There is a dropdown that lets you chose the version.

I have now switched your account to php version 5.6
 

new49ers

New Member
Messages
16
Reaction score
0
Points
1
Thank you so much Anna. I just went there and it is back up. I am really grateful, thank you for doing this for me.
 

new49ers

New Member
Messages
16
Reaction score
0
Points
1
Anna, in looking through the different features I still get a message at the top of the screen that says my version is not up to date. It wants me to update to 3.2.9 and says it is currently 3.2.2

Is this a problem? I only ask because you said you updated it to 5.6, but I don't see that anywhere yet.

Thanks again,

Jim
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
Php version is set at 5.6, php has never came in those version number so what you see is entirely unrelated to that.

Where exactly do you see that prompt to update?
 

new49ers

New Member
Messages
16
Reaction score
0
Points
1
Php version is set at 5.6, php has never came in those version number so what you see is entirely unrelated to that.

Where exactly do you see that prompt to update?

Sorry to reply so late Anna, I way away all day. I will copy and paste what I see when I log in to my admin control panel:
__________________________________________________
Welcome to phpBB
Thank you for choosing phpBB as your board solution. This screen will give you a quick overview of all the various statistics of your board. The links on the left hand side of this screen allow you to control every aspect of your board experience. Each page will have instructions on how to use the tools.

Your phpBB installation is not up to date.

Re-Check version · More information »

A new feature release 3.3.0 is available. Please read the release announcement to learn about what it has to offer, and how to upgrade.

_________________________________________________

Another thing that concerned me, possibly about updates, is in my admin control panel, under "Extensions" the only option listed on the menu is "Thanks Settings". I really need the other extensions I had previously.
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
I suspected that the message you saw came from the script you are using, what I did was change version on the server software that allows phpBB to run in the first place. We never touch the files / folders you have unless needed to get the site running, ie if the files have wrong permissions or similar.

As for updating your script, in general it is always wise to keep the scripts up to date to avoid having insecure scripts running. Weather or not you should do it depends on a couple things though, if you have plugins for phpBB you would need to make sure those are compatible (or have an upgrade version that is) with the latest version before upgrading
 

jcinycx1

New Member
Messages
3
Reaction score
0
Points
1
I have similar problems with my x10 site. According to the Direct Admin I set to run version 7.3
2020-01-27_8-27-45.png
but WordPress says I'm running version 5.5.38...why aren't these agreeing? Wordpress can't upgrade, and I also can run elementor because of this. Please help! 2020-01-27_8-36-06.png
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
I see that you are using cloudflare for your domain, did you update the A record there to reflect the new IP that came with the new server? If not, you'd be using your site from the old server.

The IP for your server is: 198.91.81.14
 

new49ers

New Member
Messages
16
Reaction score
0
Points
1
I suspected that the message you saw came from the script you are using, what I did was change version on the server software that allows phpBB to run in the first place. We never touch the files / folders you have unless needed to get the site running, ie if the files have wrong permissions or similar.

As for updating your script, in general it is always wise to keep the scripts up to date to avoid having insecure scripts running. Weather or not you should do it depends on a couple things though, if you have plugins for phpBB you would need to make sure those are compatible (or have an upgrade version that is) with the latest version before upgrading

Anna, thank you again for looking into this. I am not sure I understand what you are explaining. I have done nothing to any scripts, I am not sure I even know what they are. All I know is that when I open my admin control panel I see that the version I am running is 3.2.2.
I have changed nothing since my site went down.
Under "Extensions" the only option listed on the menu is "Thanks Settings". It almost seems like although you changed the version, my control panel is still showing the old version, even though the site itself is changed to the new version you implemented.
 

Anna

I am just me
Staff member
Messages
11,430
Reaction score
547
Points
113
phpBB = A phpscript (a forum in this case) installed in your account, this is what is asking you about updating <- I didn't touch that in any way.

php = The serverside program that translates the above srcipt into a website (a forum in this case) <- This is what I changed the version of.
 

spacresx

Community Advocate
Community Support
Messages
1,178
Reaction score
90
Points
48
@new49ers
as Anna said, your phpBB is saying its out of date, that is not the php you use.
you need to update your phpbb (your phpbb is a forum script)

the scripts are not exactly related to x10's hosting, they are just provided to use.
unless you install your own scripts. just saying.
 

spacresx

Community Advocate
Community Support
Messages
1,178
Reaction score
90
Points
48
@ jcinycx1
maybe try downgrading your php version to 5.6 or 7.0 then try the upgrade.
my php version only goes to 7.2 but make sure you set the values you need.
i seen a few versions without anything checked on them.
(and those usually cause issues)
 

magico10

Member
Messages
53
Reaction score
0
Points
6
Given the error message I'd say you would need to change php version to 5.6 (mysql_ are depreceted and removed with php 7.0), make sure to check the functions needed, mysql at a minumum.

You'll find the option to switch php version under "Extra Features"

Could anybody please tell me or give me some info about the functions are needed to my site? Apart from mysql.

Thanks!
 
Status
Not open for further replies.
Top