Root giving a 404 not found

Status
Not open for further replies.

critter74854

Member
Messages
72
Reaction score
4
Points
8
My guess is, there's something going wrong with WordPress.
The rest of the webpage loads up fine, it's only the home page. Home pages are usually index.php (for php sites like WP)
What exactly I'm sorry I don't know.
 

compu125

New Member
Messages
11
Reaction score
0
Points
1
Do you have the index.php under the public_html folder. When i type in that address in directly thats http://coachmarkjohnson.x10.mx/public_html it should automatically pickup the index.php if you have your front page named home it will not work. Or you can try a save as your index.php to index.html or vice versa and load them both under public_html. One last thing you can try is a save home1 or 2 as index.php and load it to the public folder. There could be a formatting issue in the original page.
 

compu125

New Member
Messages
11
Reaction score
0
Points
1
If home 2 and the regular index page are the same then make a copy of home 2 and save it as index.php all your links will be preserved. Delete the original index.php first and before u upload the new page check the website in the browser to make sure your heading is not coming up and you get a 404 page not found if you get the same error then delete the error page in your public folder if you have one.
What are you using for your web design tool?
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
THEY are Not the same - WordPress is a PHP site.....
the home-2 is HTML and the index.php is PHP
 

compu125

New Member
Messages
11
Reaction score
0
Points
1
can you view the wordpress php in a offline web browser and php needs to be small print
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
PHP is usually brief and loads other PHP's that selectively (by Theme) loads and serves HTML...
 

compu125

New Member
Messages
11
Reaction score
0
Points
1
Here's another option in cpanel go to the bottom and look in advanced for error pages. There will be a listing for 404 errors see if that gives you any hints as to what is going on.

http://computerdoctor.x10.mx
 

Anna

I am just me
Staff member
Messages
11,414
Reaction score
546
Points
113
The 404 error is generated by wordpress, what is wordpress set to show as first page in settings?
I think what happened is that wordpress was set to use the original home page as landing page, you removed that without changing what landing page you wanted to use, the new seem to be named home-2 if I understand you correctly.

The way I see it without being able to see what the backend (meaning what you see logged in as admin) is, that you would either need to change the setting (settings->reading) for what wordpress will use as front page to be the new page, home-2, or edit that page and rename it, or rather its permalink, to home
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
I have Error Pages - which allow you to go to your own url when an Error occurs
I don't have Error Log - in cPanel that I know of...
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
NO - all "was" working fine - I think it has something to do with me Deleting the Home Page (trying to get rid of extra Home on Menu)
The Home page is back (home-2) - - - I think it is related to the missing Home and I don't know how to get it bach. I know that the Pages are Saved with the NAME initally keyed & saved - after that yiou candelete / change the Page Name and still you will always get to it by the original Name.....
 

Anna

I am just me
Staff member
Messages
11,414
Reaction score
546
Points
113
It is not a coding issue, it is a matter of settings, wp is set to display a now removed page as the front page, that needs to be altered through wordpress admin area.
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
No - I don't think so. The Static Home Page is set to Home...
If I change it to About - Then the Seconh Home goes to About while the First Home still gives an error..
 

paulx10h

Member
Messages
31
Reaction score
0
Points
6
WAIT - I think you have something
The Second Home goes to Home and the First Home goes to About
I'll change it back...
THAT fixed it
I changed Static to About - OK
I changed it back to Home - now the Second Home is gone and the Menu Home is working OK

Bet you don't know how to change the background color of the Header (removed or not) especially - when removed there is that bad pink color...
I have tried all of these (one at a time) and they don't do it:
#header {
background-color:#FFF8DC;
}
#header_area {
background-color:#FFF8DC;
}
#header_area {
background: url('http://www.whenlifegivesyoulemons.com.au/images/lemon-logo.png');
background-repeat: no-repeat;
background-size: 100%;
}

Thanks for your help.
Paul
 
Last edited:
Status
Not open for further replies.
Top