Resolved Security Risk After Turning on SSL

Status
Not open for further replies.

themich2

New Member
Messages
7
Reaction score
1
Points
3
I was following a guide for improving security in Wordpress since it gave me a list of things to do for this. One of those things was having https to have a more secure website.

I went into control panel of x10hosting, then Domain Setup -> My Domain, and then toggled on Secure SSL, then chose to force a redirect to themichaelminer.com (my domain). When I went to visit the site to check it had changed to https, but Firefox is now giving me a "Potential Security Risk Ahead" message. If I except the risk and continue my website is completely blank and read "Apache is functioning normally".

I did toggle undo everything I changed to see if it would return to normal, but it's not. Can anyone please help me. I clearly should not have messed with this setting, but I thought if it didn't work undoing would fix it, I didn't think it would cause such a huge problem.
 

themich2

New Member
Messages
7
Reaction score
1
Points
3
This doesn't seem to happen when I go to my website in Firefox or Chrome using Private or Incognito browsing

Safari goes to the site no problem. Is it some sort of caching issue with the browser? I already deleted cookies and clear cache.
 
Last edited:

garrettroyce

Community Support
Community Support
Messages
5,604
Reaction score
245
Points
63
I get PHP errors on your non-https site and it does not redirect me. Your https site has security errors.

Consider using CloudFlare (or etc.) on x10hosting free (premium is different). It's about the only way to do this and get proper security. You must use flexible mode when you turn the service on.
 
Status
Not open for further replies.
Top