The GD Library is not enabled by default on my subdomain.

Status
Not open for further replies.

hexagon theory

New Member
Messages
1
Reaction score
0
Points
0
While I've read all over the place that PHP's image manipulation library is supposed to be enabled by default on all accounts, I fear this has not proven true for mine. A demonstration:

http://i41.tinypic.com/o9r72b.png

I'd really like to figure out what's going on here; is there perhaps some delay during which some behind-the-scenes processing goes on before certain aspects of a free account are implemented? Any help would be greatly appreciated.
 

tiller

New Member
Messages
2
Reaction score
0
Points
0
Up until 24 hours ago, GD was working perfectly on starka.
Today it's not.
 

dyreplus

New Member
Messages
29
Reaction score
1
Points
0
It's my understanding that GD Library is a feature of INTERMEDIATE PHP. If you had a site before they changed the php settings and had intermediate, that has been returned set up again. However, if you made a site after that point, you have BASIC PHP which does not include GD Library.
 

jessesopher

New Member
Messages
10
Reaction score
0
Points
0
Is there any way to upgrade to the Intermediate? On my account page, when I click the Upgrade PHP version button, it says that this option is not available for my account. I opened a support ticket yesterday about the GD Library issue and responded today about upgrading the PHP version. But I haven't heard anything from admins at all. Any ideas?
 

tiller

New Member
Messages
2
Reaction score
0
Points
0
dyreplus, I can't recall if GD needed INTERMEDIATE when I signed up (my application needed intermediate from the get go for other reasons, not GD, so I upgraded right away), but the fact is that it had been working perfectly for almost a month, up until yesterday. When did the PHP settings change? I must have missed some thread here...
Now, as jessesopher says, the PHP upgrade feature does not exist in the account pages.
This leaves me without graphs for the moment and it's quite annoying... :rant2:
 

Naysha

New Member
Messages
105
Reaction score
1
Points
0
dyreplus, I can't recall if GD needed INTERMEDIATE when I signed up (my application needed intermediate from the get go for other reasons, not GD, so I upgraded right away), but the fact is that it had been working perfectly for almost a month, up until yesterday. When did the PHP settings change? I must have missed some thread here...
Now, as jessesopher says, the PHP upgrade feature does not exist in the account pages.
This leaves me without graphs for the moment and it's quite annoying... :rant2:

i am agree with you, i am also waiting for some answer, i need intermediate version too, i have opened a ticket also... i hope this could be solved very soon. :dunno:
 
Messages
740
Reaction score
1
Points
18
Not sure on the answer to this one to be honest with you people. Hopefully someone with a little more knowledge could come in and confirm with you.

If you've submitted a support ticket please be patient waiting for an answer. The staff are dealing with tickets and as you may have noticed lots of people have had problems with accounts and such and this has taken it's toll on the amount of tickets that have been received. Staff would be most thankful if you would wait patiently and they will reply as soon as they can. In the meantime all we can do is wait and apologise for the inconvenience that is being caused and hope you understand.
 

garrettroyce

Community Support
Community Support
Messages
5,603
Reaction score
246
Points
63
PHP must be compiled with or without extensions, like GD. Right now, it is compiled without GD so it will not be possible for anyone to use it, at least on Stoli. I don't know if this is on purpose or accident.

Hope this clears up some confusion.

I really hope this is re-enabled because my site is based upon its availability.
 
Last edited:

jsuthers

New Member
Messages
5
Reaction score
0
Points
0
Well whats weird is that it was working fine yesterday..... my game script which used this code....

PHP:
if ($do[0] == "makemap") { makemap(); }
function makemap() {
    global $userrow, $controlrow;
    $latitude = $userrow["latitude"];
    $longitude = $userrow["longitude"];
    $map = imageCreate(500,500);
    $magenta = ImageColorAllocate($map, 255, 0, 255);
    $red = imageColorAllocate($map, 211, 0, 0);
    ImageColorTransparent($map, $magenta);
    imageFilledEllipse($map, ($longitude + 250), (-$latitude + 250), 10, 10, $red);
    header("Content-type: image/png");
    imagePNG($map);
    imageDestroy($map);
}

it worked just fine the other day....... but when i logged in today.... the site was running HORRIBLY(plus dot was not showing up) so i thought i would delete database and files and start over....... and welll page load it better.... but GDLIB is no longer working......
 

AsianX

New Member
Messages
10
Reaction score
0
Points
0
Received word from admin..

"All account are currently using a default PHP config while the PHP upgrade system is finished."

So if you need or had phpv2, itll have to wait until after the upgrades are done.

And... there is no ETA on how long this will take.. be patient.. Try not overload support with tickets regarding phpv2, Im sure it wont be much longer.

Cha~
 

Youmoussa

New Member
Messages
10
Reaction score
0
Points
0
Same problem here.. Did I miss something or didn't they warn about that?

My website needs the GD library and I just realized that I have been downgraded from Intermediate to basic..
 
Last edited:
Messages
740
Reaction score
1
Points
18
Think it may have been mentioned in the announcements forum.

Until the php is sorted for the new backend - perhaps that should be the other way round!? I'm too tired anyhow! - then x10Hosting has a set php level for everyone.
 

sgrpdl

New Member
Messages
63
Reaction score
0
Points
0
I'm in Cossacks.x10 and previous my php ver~ was Intermediate level but now it shows Basic.
And coz of this i guess my sub domain photo gallery sites shows Error: GD Library no installed................ :(

Hope they gona fix this soon.
 
Status
Not open for further replies.
Top