xampp vs x10hosting

Status
Not open for further replies.
Messages
49
Reaction score
0
Points
6
Hola gente, como estan? Tengo una consulta para hacerles. Y la verdad es que necesito su ayuda urgentemente. La cuestion es la siguiente: Tengo un servidor web casero con el XAMPP 1.7.3 montado sobre un xp sp3 con todos sus Addons respectivos y andando supuestamente. Lo que quiero hacer es podes usar TEMPLATES php en el servidor y que me funquen. El ejemplo que estoy implementando es uno que rescate de una pagina para hacer un foro. Les escribo el codigo:

Archivo ejemplo.php
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>ejemplo.php</title>
</head>

<body>
<?php
function mostrarTemplate($tema, $variables)
{
//var_dump($variables);
extract($variables); eval("?>".$tema."<?");
}
$agenda = array("0" => array("nombre"=>"Marcelo", "edad"=>"25", "domicilio"=>"Veracruz 324"),
"1" => array("nombre"=>"Alejandra", "edad"=>"18", "domicilio"=>"sobala 324"),
"2" => array("nombre"=>"Pepito", "edad"=>"28", "domicilio"=>"Me la como 324")
); $tpl = implode("", file("ejemplo.html"));
foreach($agenda as $registro)
{
mostrarTemplate($tpl, $registro);
}
$string = 'cup';
$name = 'coffee';
$str = 'This is a $string with my $name in it_<br>';
echo $str;
eval( "\$str = \"$str\";" ); echo $str;
?>
</body>
</html>

Archivo ejemplo.html
<html>
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>ejemplo.html</title>
</head>
<body>
Nombre: <b> <?=$nombre?> </b><br>
Edad: <b> <?=$edad?> </b><br>
Domicilio: <?=$domicilio?>
<hr>
</body>
</html>

el tema es que cuando lo ejecuto en mi host de x10hosting funciona a la perfeccion pero cuando lo corro desde mi servidor no funciona como deberia. O sea no aparecen los valores de las Arrays y en la parte de echo del primer $str no sale en la pagina. Las direcciones son:
mi cuenta x10hosting - www.serviciosdobled.com.ar/ejemplo.php
muestra2..JPG

mi servidor xampp - http://serviciosdobled.dyndns.org/ejemplo.php

muestra1..JPG

Lo que yo quiero saber es cual es la diferencia entre mi servidor y el de x10hosting. Y como puedo resolverlas para que mi servidor con XAMPP funcione como el de ustedes para que pueda usar todas las funciones del lenguaje PHP y MySql tambien. Que es lo que tengo que agregar, o modificar en mi XAMPP para que ande igual? Por favor si alguien puede ayudarme o sabe de alguien estoy a la espera.

Desde ya muchas gracias.
 

papichulo_carioco

Community Advocate
Community Support
Messages
1,416
Reaction score
12
Points
0
pues me temo que eso es cuestion del archivo php.ini, es decir de la configuración del php, cosa que en x10 no tenemos acceso. Sólo los admin pueden ver ese archivo y configurarlo al gusto ;)
 

papichulo_carioco

Community Advocate
Community Support
Messages
1,416
Reaction score
12
Points
0
Pues el unico que puede hablar español es Alejandro y no creo que lo puedas contactar. El dueño es Corey, pero no creo que te atienda por mp. Mejor pones un ticket en el area de soporte explicando que es lo ue quieres que te modifiquen ;)
 

includes

New Member
Messages
10
Reaction score
1
Points
0
Tu codigo me fue bien en mi servidor local

Revisa las extensiones en el php.ini aqui te dejo las que yo tengo activadas


Code:
extension=php_mbstring.dll
extension=php_bz2.dll
extension=php_curl.dll
;extension=php_dba.dll
;extension=php_dbase.dll
extension=php_exif.dll
;extension=php_fdf.dll
;extension=php_filepro.dll
extension=php_gd2.dll
;extension=php_gettext.dll
;extension=php_ifx.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
extension=php_mcrypt.dll
;extension=php_mhash.dll
;extension=php_mime_magic.dll
;extension=php_ming.dll
extension=php_mssql.dll
;extension=php_msql.dll
extension=php_mysql.dll
;extension=php_oci8.dll
extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
extension=php_sockets.dll
extension=php_sqlite.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
;extension=php_xmlrpc.dll
;extension=php_xsl.dll
extension=php_zip.dll
 
Messages
49
Reaction score
0
Points
6
Tu codigo me fue bien en mi servidor local

Revisa las extensiones en el php.ini aqui te dejo las que yo tengo activadas


Code:
extension=php_mbstring.dll
extension=php_bz2.dll
extension=php_curl.dll
;extension=php_dba.dll
;extension=php_dbase.dll
extension=php_exif.dll
;extension=php_fdf.dll
;extension=php_filepro.dll
extension=php_gd2.dll
;extension=php_gettext.dll
;extension=php_ifx.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
extension=php_mcrypt.dll
;extension=php_mhash.dll
;extension=php_mime_magic.dll
;extension=php_ming.dll
extension=php_mssql.dll
;extension=php_msql.dll
extension=php_mysql.dll
;extension=php_oci8.dll
extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
extension=php_sockets.dll
extension=php_sqlite.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
;extension=php_xmlrpc.dll
;extension=php_xsl.dll
extension=php_zip.dll

Me sigue sin funcionar. El httpd.conf no tengo que modificarlo tambien?. Que servidor web tenes instalado exactamente? Y como lo configuraste? De paso te pregunnto que en que sistema operativo porque no me va. Fijate la diferencia entre www.serviciosdobled.com.ar/ejemplo.php y maquiblas.dyndns.org/templates/ejemplo.php
Tendra algo que ver el firewall o el antivirus?
La verdad es que estoy buscando y no encuentro nada en ningun sitio.
Y hace unos dias cambiando cosas en el php.ini y en el httpd.conf el server apache cuando arranca me tira: Module 'mysql' already loaded (2 veces) y luego
PHP startup: unable to load dynamic library 'D:\xampp\php\ext\php_openssl.dll - No se puede encontrar el modulo especificado. Y cuando les doy aceptar vuelve a aparecer todo otra vez y ahi arranca el apache.
 
Last edited:

includes

New Member
Messages
10
Reaction score
1
Points
0
Yo uso lighttpd en win32 y instale mi propio php

Si te falta alguna libreria de php buscala en php.net aun que en realidad openssl no resolvera tu problema asi que la puedes quitar si no la usaras , Sobre mysql es que ya esta usando otra extension de mysql quita alguna

No creo que el problema sea con la configuracion de apache sino con la de php

El firewall ni el antivirus tienen que ver

Te dejo mi archivo php.ini para que lo compares con el tuyo. Ignora la extension zend

Otra cosa estas si estas usando xampp lite te recomiendo mejor la full.
 

Attachments

  • php..txt
    46.1 KB · Views: 17
Last edited:
Messages
49
Reaction score
0
Points
6
No me podrias mandar tu PHP.INI y el HTTPD.CONF a mi mail? o subir los archivos aca para que los pueda bajar? Te dejo mi mail por las dudas?
Gracias.
Otra cosa, estoy usando el XAMPP 1.7.3 FULL creo. Lo baje de la pagina de apache friends. Y ese programa que usas cual es? No lo conocia. Difiere mucho del XAMPP?
Tengo el apache y el php con mysql en otro servidor instalados por separado. Me conviene?
 
Last edited:
Messages
49
Reaction score
0
Points
6
Last edited:

includes

New Member
Messages
10
Reaction score
1
Points
0
Ya me fije todas las extensiones y arregle los mensajes de error pero me sigue sin funcar. Alguna ayuda mas?
Como hago para que esto le llegue a algun admin tambien?
Por favor si alguien sabe de algo avisenme.
Subo mis archivos PHP.INI y HTTPD.CONF para que los puedan revisar si quieren.
Gracias.View attachment 4940
View attachment 4941
View attachment 4942

Ya vi tu problema abre tu php.ini y cambia

short_open_tag = Off

por

short_open_tag = On

Recuerda reiniciar el servidor.


lighttpd es una alternativa a apache
 
Last edited:
Messages
49
Reaction score
0
Points
6
Ya vi tu problema abre tu php.ini y cambia

short_open_tag = Off

por

short_open_tag = On

Recuerda reiniciar el servidor.


lighttpd es una alternativa a apache

Era eso nomas!, gracias por tomarte la molestia de dedicarme un tiempo!
La tenes clara evidentemente, hace mucho que haces o sabes de esto? Estas estudiando una carrera sobre esto?
 
Status
Not open for further replies.
Top