Php.ini upload_max_filesize 2M

Discussion in 'Free Hosting' started by recipegu, Aug 1, 2016.

Thread Status:
Not open for further replies.
  1. recipegu

    recipegu New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Hello, on my website users can upload images. But i noticed that these uploads are only limited to 2M, which is fine for the most part. Can you possibly increase the upload_max_filesize limit to something like 5M?

    PS- When the user uploads the image I process it in ImageMagick to reduce the filesize used so I am trying to keep my storage low.

    Thank you
     
  2. irisx174

    irisx174 New Member

    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    are u using wordpress?
     
  3. recipegu

    recipegu New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    No, it is my own custom code(html/php). Thanks for the reply though
     
  4. bdistler

    bdistler Well-Known Member Prime Account

    Messages:
    3,534
    Likes Received:
    196
    Trophy Points:
    63
    on my x10hosting's free-hosting server [ xo3 ] - this script:
    PHP:
    print "\"PHP maximum upload file size\" is ==>" ini_get('upload_max_filesize') . "<==";
    shows --> [ "PHP maximum upload file size" is ==>16M<== ]
     
  5. Corey

    Corey I Break Things Staff Member

    Messages:
    34,553
    Likes Received:
    202
    Trophy Points:
    63
    You should be able to change the max upload size from the PHP options in cPanel. I believe it's under the PHP selector icon.
     
  6. bdistler

    bdistler Well-Known Member Prime Account

    Messages:
    3,534
    Likes Received:
    196
    Trophy Points:
    63
    on my free-hosting account...

    on cPanel x3's [ homepage ] --> [ Select PHP Version ] --> [ Switch to PHP Settings ]
    only has [ file_uploads ] which is a ON or OFF to "Allows uploading files over HTTP"
     
  7. recipegu

    recipegu New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    When I check my php settings I see it just like bdistler has mentioned.

    I am on server xo5 and I ran the ini_get('upload_max_filesize') function. It is showing 2M.
     
  8. Dead-i

    Dead-i x10Hosting Support Ninja Community Support

    Messages:
    6,084
    Likes Received:
    367
    Trophy Points:
    83
    Hi recipegu,

    I have bumped the maximum upload size for the PHP 7.0 configuration on xo5 to 16MB (which is the limit for free hosting accounts). I also found your test script, which looks to now be reporting the new 16MB setting, but please do let us know if you have any more problems.

    Thank you,
     
    • Like Like x 1
  9. recipegu

    recipegu New Member

    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Thank you very much Dead-i! It appears to be working great!

    You can closed the thread if you would like.
     
  10. andygrig

    andygrig New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Could you please adjust my file upload size as well? Many thanks.
     
  11. caftpx10

    caftpx10 Well-Known Member

    Messages:
    1,535
    Likes Received:
    114
    Trophy Points:
    63
Thread Status:
Not open for further replies.

Share This Page