500 errors/Slow Loading

marvso

Member
Messages
61
Reaction score
0
Points
6
x10hosting, I love you. When I first signed up everything worked great, the support was awesome, and the services became better and better. And while this past summer things have been a little bumpy with server uptime, to the point I actually considered moving hosts, you redemmed yourself and came out on top as one of the best free website hosts (just you claim to be).

However, these past few weeks I have noticed a substantial amount of 500 errors and slow loading times: almost to the point I find navigating my site completely unbearable. I understand this is the nature of free hosting (especially one that uses cPanel), some days the speed is likely to be better than others, but the fact that I am noticing it more and it's getting progressively worse is worrisome. I'm kind of curious as to why this is happening. Are we off to another repeat of downtime and data loss? Or are there solutions in the works to fix these problems?

Beyond that complaint, however, thank you x10 for being a wonderful hosting service!
 

nandifamily

Member
Messages
174
Reaction score
2
Points
18
heavy server load is the problem. since it is a cluster. connection to databases n web servers are hitting the roof.
 

Corey

I Break Things
Staff member
Messages
34,553
Reaction score
203
Points
63
Some changes were made a few days ago that should make a pretty big difference.
 

marvso

Member
Messages
61
Reaction score
0
Points
6
Yeah, I noticed the speed has gotten a world better! Thank you!
 
Top