CloudFlare change name servers help needed

GovzLegacy

New Member
Messages
4
Reaction score
0
Points
1
I've recently added cloudflare to my website but the URL still displays the website as not secure. When I click on the Cloudflare icon on the x10hosting control panel it says that my website is currently powered by CloudFlare, but when I visit back to my site it does not say secure. I applied for CloudFlare on September 10th 2017 at approximately 1pm and now more than 48hours have passed since then.
CloudFlare suggested that I needed to change my name servers from,
ns1.x10hosting.com to
ed.ns.cloudflare.com

and,
ns2.x10hosting.com to
erin.ns.cloudflare.com
but i couldn't find this option in the control panel. Help would be greatly appreciated.
 

GovzLegacy

New Member
Messages
4
Reaction score
0
Points
1
You need to log in at https://www.cloudflare.com/ , go to Crypto and select the Flexible SSL option. There may additional steps you need to take depending on your site.

Thanks for your prompt response! I have already set it to flexible 5 days ago. I have attached an image and as you can see it says last change was made 5 days ago.

If you could please shed some light on what these other steps might be that I need to do that would greatly help. Thanks!
 

Attachments

  • chrome_2017-09-15_17-46-16.png
    chrome_2017-09-15_17-46-16.png
    24.7 KB · Views: 13

GovzLegacy

New Member
Messages
4
Reaction score
0
Points
1
I have very limited knowledge of htaccess, however I did a bit of research and came across this line of code and tried using it:

RewriteEngine On
RewriteCond %{HTTP_HOST} !^(www\.)?govzlegacy.x10host\.com$ [NC]
RewriteRule ^(.*)$ https://www.govzlegacy.x10host.com/$1 [R=301,NE,L]

there was not change at all.

I also tried changing the '.com' to '.tld' as you suggested like so:

RewriteEngine On
RewriteCond %{HTTP_HOST} !^(www\.)?govzlegacy.x10host\.com$ [NC]
RewriteRule ^(.*)$ https://www.govzlegacy.x10host.tld/$1 [R=301,NE,L]

However this brings up a timed out error connection message in the browser. The browser continuously tries to connect but never gets anywhere.

I also tried adding Page Rules in Clouldflare as they suggested to do redirects (see attachment '1'), however that failed too. Nothing happens.
I tried turning on the option called 'Always use HTTPS' in the crypto menu, however again no luck there as well (see attachment '2').

When I log into Cloudflare it says that i have not yet finished the set up process (see attachment '3').
Clicking on continue keeps taking me to the same page about name servers (see attachment '4').

I have tried going to the 'Advanced DNS Zone Editor' setting in cPanel but again there are no name servers there that say ns1.x10hosting.com and ns2.x10hosting.com

I am just completely lost...
 

Attachments

  • 1.png
    1.png
    34.9 KB · Views: 4
  • 2.png
    2.png
    13.6 KB · Views: 3
  • 3.png
    3.png
    34 KB · Views: 3
  • 4.png
    4.png
    64 KB · Views: 4

danielle.seiley61

Member
Prime Account
Messages
91
Reaction score
2
Points
8
I've recently added cloudflare to my website but the URL still displays the website as not secure. When I click on the Cloudflare icon on the x10hosting control panel it says that my website is currently powered by CloudFlare, but when I visit back to my site it does not say secure. I applied for CloudFlare on September 10th 2017 at approximately 1pm and now more than 48hours have passed since then.
CloudFlare suggested that I needed to change my name servers from,
ns1.x10hosting.com to
ed.ns.cloudflare.com

and,
ns2.x10hosting.com to
erin.ns.cloudflare.com
but i couldn't find this option in the control panel. Help would be greatly appreciated.
Sorry about my late response, but to make this happen you need to go to your domain registrar. Whether it be godaddy, Google Domains, Namecheap, or whoever you registered your domain name with. Only there will you be able to change your nameservers. However if you are using one of the free x10 hosting .com addresses you get as a free customer you will not be able to change your nameservers.

Hope this helps.
 
Top