Increase "max_input_vars"?

Discussion in 'Free Hosting' started by clovis9, May 26, 2013.

Thread Status:
Not open for further replies.
  1. clovis9

    clovis9 New Member

    Hi,

    I am getting the following error with my XenForo install:
    Code:
    [COLOR=#141414][FONT=Consolas]parse_str(): Input variables exceeded 1000. To increase the limit change max_input_vars in php.ini.[/FONT][/COLOR]
    Would it be possible to increase the: max_input_vars to, say 2000?
    That would be great.

    Thanks,
    Clovis

    Server: Level
    Last edited: May 26, 2013
  2. iSean

    iSean Member

    That's strange, I managed to install XenForo easily with no errors :S

    http://codewm.com <

    Are you using a nulled version?
  3. bdistler

    bdistler Member Prime Account

    While there might be a error - after the current system update - in the size of that limit - it is set for all accounts on your server
    UPDATE: I do not think it is a error - my "Premium" account has PHP [ max_input_vars ] set to 1000

    IMO x10hosting will not change it

    It is a setting in PHP - starting with verson 5.3.9 - called max_input_vars, which limits the number of input variables that can be created at a particular array level. It defaults to 1000 which is generally more than enough.

    The setting is there to protect against a certain type of DoS attack involving hash table collisions

    ###

    If he was - his account would be terminated
    Last edited: May 28, 2013
  4. clovis9

    clovis9 New Member

    No, I am not using a "nulled" XenForo, nor did I know what it was until I google searched it.

    Wrong wording, XenForo installed correctly, but some add-ons and features require more max_input_vars to operate correctly. For example: http://xenforo.com/community/resources/rt-user-rank-ribbons.832/ requires at least 2000. Do they/would they change this for premium accounts?

    Thanks,
    Clovis
Thread Status:
Not open for further replies.

Share This Page