PHP and Emailing

Status
Not open for further replies.

joshuaowned85

New Member
Messages
11
Reaction score
0
Points
0
I created a thread about this earlier, for which no one freaking helped me, this website has terrible support teams, and no one will help me with my problem. I have a website that had a working contact form, and now when they submit it, it doesn't send anything to my email, I haven't changed anything in the scripts.

---------- Post added at 04:43 AM ---------- Previous post was at 04:42 AM ----------

Help me
 

garrettroyce

Community Support
Community Support
Messages
5,601
Reaction score
239
Points
63
Is there anything in your PHP error log? Do you have PHP error logging enabled? Are you checking the return value of the mail() function? Did you check your junk email filter?

Telling me I'm doing a terrible job doesn't really get me excited to help you, in case you were wondering.
 

descalzo

Grim Squeaker
Community Support
Messages
9,375
Reaction score
327
Points
83
Also, make sure the you have the header:

Content-type: text/plain

not text/html
 

joshuaowned85

New Member
Messages
11
Reaction score
0
Points
0
The thing is, the content is HTML, not plain, as you stated the Content-Type: text/html seems to be the problem, I changed it to plain, before reading the posts, and it had sent to my email as planned, but it no longer sends to my email when the Content-Type is text/html, it only works as text/plain ; Is there any way to fix this, or does this website no longer support it?
 

garrettroyce

Community Support
Community Support
Messages
5,601
Reaction score
239
Points
63
Descalzo is working on trying to get this solved. I will try to get back to you as soon as I know anything. If you don't hear back from me, reply in this thread and someone will update you.
 
Last edited:

garrettroyce

Community Support
Community Support
Messages
5,601
Reaction score
239
Points
63
Unfortunately, I have not seen an update to this issue. Either the admins fixed the problem and didn't notify me, or they're still working on it. There are no error messages being posted from this error, so it can be difficult to track down where the problem is happening exactly.

Please post back whenever you want a status check and I will do my best to provide the information that I have.

Alternatively, if your website supports SMTP, you can sign up for Google Apps and have Google manage your mail instead of X10Hosting. It's free, it's supported by X10Hosting, and it's a good service. I'm still going to try and get this fixed either way, but you do have options if you are unhappy with X10's mail service.
 
Last edited:

stpvoice

Community Support Rep
Community Support
Messages
5,987
Reaction score
212
Points
63
Hello,

Sorry for the delay. I've only just spotted your ticket. I hope you'll understand.
What are you running your website on? Are you using a CMS?

Thanks.
 
Status
Not open for further replies.
Top