Problem with uploading images on wordpress

Status
Not open for further replies.

iammario

New Member
Messages
12
Reaction score
1
Points
3
I either get 'HTTP error' when using the flash uploader, or 503 service unavailable when using the basic uploader.

I've googled around for a bit and I can't solve this problem.
I'm using an addon domain, and I've reinstalled my wordpress installation from scratch about 3 times now.

If you need any information about my account, let me know. I'm not sure what information to provide.
 

Attachments

  • 1.PNG
    1.PNG
    8.3 KB · Views: 14
  • 2.PNG
    2.PNG
    6.3 KB · Views: 13

iammario

New Member
Messages
12
Reaction score
1
Points
3
I see this is being looked into. Thank you very much x10 support team, you've always been very reliable for the 4-5 years that I've used you guys. Cheers.
 

leafypiggy

Manager of Pens and Office Supplies
Staff member
Messages
3,819
Reaction score
163
Points
63
We're thinking this is related to imagemagick. I'm waiting for my colleague to get back from work so we can look into this. (I don't have server access right now).

See if you can disable imagemagick in wordpress.
 

iammario

New Member
Messages
12
Reaction score
1
Points
3
We're thinking this is related to imagemagick. I'm waiting for my colleague to get back from work so we can look into this. (I don't have server access right now).

See if you can disable imagemagick in wordpress.
Haven't quite figured out how to disable imagemagick through wordpress after some googling around for a solution. I can wait. Thanks for the update.
 

theneale

Member
Messages
47
Reaction score
2
Points
8
I'm getting the same problem with a clean Wordpress 3.8.1 installation with no plugins - the server for this test installation is 'level'. My main site is currently running on Wordpress 3.8 (on 'illuminated') and is trouble free. I've just done a test clean install of 3.8.1 on illuminated and that works fine - so it looks like something related to the server 'level' configuration.
 

djthomp853

New Member
Messages
5
Reaction score
0
Points
1
If I may add something here, mine started doing it a couple days ago also, and i noticed my .htaccess file is completely empty. from what I've read, that happens when there is a problem between PHP4 and PHP5. I think that might have something to do with it.
 

webwolfx

New Member
Messages
2
Reaction score
0
Points
1
I too get this problem, but I did some testing.

It seems to be the wordpress image/media up-loader I used the plugin nextGen Gallery and images upload with no problems at all.
pic.
ibdjNLDpCdGPTi.png
 

iammario

New Member
Messages
12
Reaction score
1
Points
3
Thank you!!! I can use this while they fix this annoying problem.

Edit: sadly, this did not work for me. I am unable to use images in a way that I need to use them. The plug in is pretty broken right now too, which I suspect is a result of this underlying issue.
 
Last edited:

leafypiggy

Manager of Pens and Office Supplies
Staff member
Messages
3,819
Reaction score
163
Points
63
I think I've isolated the cause of the issue... we're running some tests before we put the fix into place and then we'll have you guys try it out.
 

m0ldyy

New Member
Messages
17
Reaction score
0
Points
1
I have the same issue. Please let us know when this is fixed. I'm going to try this "nextGen Gallery" plugin and see what happens.
 

ygweblog

New Member
Messages
25
Reaction score
6
Points
3
I'm also having the same problem and I can't upload images, not even with NextGen. :(
 

retiredk

Member
Messages
31
Reaction score
1
Points
8
I started having the same issue the other day and did some checking. Imagemagick might have a little to do with it but in actuality it's the PHP5. I'm pretty sure they allow snippets here so here goes. Add this to your .htaccess:
Code:
# Exclude the file upload and WP CRON scripts from authentication
<FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
    Satisfy Any
    Order allow,deny
    Allow from all
    Deny from none
</FilesMatch>

I had ran with it and seems to work (crosses fingers this won't jinx it). Got confirmation at this resource, Wordpress.org, which which just tweaked a line I had a little. Hope this helps.
 

alagator28

New Member
Messages
3
Reaction score
0
Points
1
I have the same problem with Wordpress 3.8.1. With certain images - NOT ALL, it will begin uploading, get to a certain percentage (always the same) and then show http error. The size of the images aren't any bigger (and in some cases quite a bit smaller) than others which work. I've tried the following without success:
  • Tried renaming .jpg to .png.
  • Disabled as many plugins as possible without affecting woocommerce functionality.
  • Tried adding code to .htaccess file (shown above and on other forums).
  • Tried Nextgen Gallery. Same upload percentage, fails.
  • Tried the same image on another Wordpress site I have (still on version 3.3.1) and it works fine.
Any ideas?
 

classic6

New Member
Messages
6
Reaction score
0
Points
1
I started having the same issue the other day and did some checking. Imagemagick might have a little to do with it but in actuality it's the PHP5. I'm pretty sure they allow snippets here so here goes. Add this to your .htaccess:
Code:
# Exclude the file upload and WP CRON scripts from authentication
<FilesMatch "(async-upload\.php|wp-cron\.php|xmlrpc\.php)$">
    Satisfy Any
    Order allow,deny
    Allow from all
    Deny from none
</FilesMatch>

I had ran with it and seems to work (crosses fingers this won't jinx it). Got confirmation at this resource, Wordpress.org, which which just tweaked a line I had a little. Hope this helps.

I tried this.. It didnt work :(
 

buildthi

New Member
Messages
3
Reaction score
0
Points
1
I think I've isolated the cause of the issue... we're running some tests before we put the fix into place and then we'll have you guys try it out.

Any word on when this fix will be rolled out? Its been 6 days and still nothing...
 

davdaddy

New Member
Messages
19
Reaction score
1
Points
3
Been having this issue as well, gunna try the .htaccess workaround. I'll post back if it works for me.

*update:
No dice with .htaccess
 
Last edited:

najinand

New Member
Messages
1
Reaction score
0
Points
1
Status
Not open for further replies.
Top