SEF on Joomla and the .htaccess


New Member
Reaction score
Hello peeps,

Recently i had some issues with Joomla SEF when I was realocated from one server to another. So I thought of posting how I fixed it in order to help other people who had problems with it.

1) Under administration panel>Global Configuration>Site you should see SEO Settings in the right part of the screen. Enable SEF (Serach Engine Friendly URLs) and Apache's mod_rewrite.

2) Next go to your cpanel. Open File Manager. A popup window will appear, regarding File Manager Directory Selection. Tick the Show hidden files, in the bottom of the window.* (check Notes at the bottom)

3)Go to your Joomla site directory, right click in the htaccess.txt file and click edit. Copy its contents. Close the file.

4)In the public_html you should see a .htaccess file. Right-click and click edit. Paste the information below what's already there, do not overwrite.

5) Make sure these lines are not commented (if the line sbeggin with #, remove the #)

  • Options +FollowSymLinks
  • RewriteEngine On
  • RewriteBase /

6) If your joomla is localted in your public_html folder, you're done. If not proceed to the next step

7) In your joomla directory, create a .htaccess file. Open the file and write:
RewriteBase /[path to joomla] where [path to joomla] is the relativate path of your joomla folder to root. Path is case sensitive
ex: If my Joomla is located in /public_html/joOmLa/ then i will write RewriteBase /joOmLa

8) Test and see if it works.

Note: If you can't see the .htaccess file and when you start file manager the pop-up window doesn't appear ---> go to your cPanel, scroll to the bottom and click "reset all interface options". the pop-up window will now appear. (thanks to Hellsheep)