Service taking too much resources

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
I think I may have a virus, or the remnants of a virus because my process "svchost.exe" is taking upwards of 100,000 k and if I'm not mistaken, that is a bit too much.

Can someone tell me how to find which service is taking up so much memory and fix this?
 

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
"Blaster worm not found on your system"

Anything else it could be?
 

Smith6612

I ate all of the x10Pizza
Community Support
Messages
6,518
Reaction score
48
Points
48
Run MalwareBytes and SUPERAntiSpyware just for safe measure to make sure things are clean. If svchost.exe (Take note of the name! Malware likes to disguise itself as scvhost.exe or svchast.exe) is only using 100% CPU for a few minutes, it's possible Microsoft Update is to blame, which I've seen on some PCs.
 

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
I'm afraid neither of those worked. Both said they found nothing and svchost is still 100,000+k.

Any other ideas?
 

Smith6612

I ate all of the x10Pizza
Community Support
Messages
6,518
Reaction score
48
Points
48
Go to Start > run or Start > Search bar (if running Windows Vista/7) and type in services.msc . Once there, shut down the Automatic Updates service. See if the svchost.exe memory usage drops.
 

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
The automatic update for windows? 'Cuz that didn't change it.
 
Last edited:

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
Strange Process Usage viewed with Process Explorer

Ok, I looked into it a little more using Process Explorer and found something strange.

My process svchost.exe is taking up [at the moment] 144k but all the underlying services add up to no more than 15k. Can anyone explain?
 
Last edited:

Smith6612

I ate all of the x10Pizza
Community Support
Messages
6,518
Reaction score
48
Points
48
Re: Strange Process Usage viewed with Process Explorer

Ok, I looked into it a little more using Process Explorer and found something strange.

My process svchost.exe is taking up [at the moment] 144k but all the underlying services add up to no more than 15k. Can anyone explain?

Post up what you see for Process Explorer including any details it gives about the affected svchost.exe process. Screenshots are appreciated.
 

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
Re: Strange Process Usage viewed with Process Explorer

Is this enough information?
 

Attachments

  • svchost_help_current-2-8-11.png
    svchost_help_current-2-8-11.png
    6.8 KB · Views: 18

Sharky

Community Paragon
Community Support
Messages
4,397
Reaction score
91
Points
48
Try right clicking on it in windows task manager then Show Processes. There'll be a load of windows services selected in the services tab.
 

sikuneh

New Member
Messages
55
Reaction score
0
Points
0
wudfsvc
WPDBusEnum
Wlansvc
UxSms
TrkWks
SysMain
PcaSvc
Netman
IPBusEnum
HomeGroupListener
AudioEndpointBuilder
 

warlordste

New Member
Messages
653
Reaction score
0
Points
0
I would back up your files and do a clean install you will sort out your promblem plus more than likely speed up your computer for a while :)
 
Top