SUHOSIN - Use of eval is forbidden

Status
Not open for further replies.

MaestroFX1

Community Advocate
Community Support
Messages
1,577
Reaction score
60
Points
0
Hi !
I am getting these errors:
1>>
Fatal error: SUHOSIN - Use of eval is forbidden by configuration in /home/USERNAME/public_html/libraries/joomla/utilities/simplexml.php(336) : eval()'d code on line 336

2>>
Fatal error: SUHOSIN - Use of eval is forbidden by configuration in /home/USERNAME/public_html/bulletin-board/includes/template.php(174) : eval()'d code on line 174

I am on Basic PHP Configuration.

Thanks
 

MaestroFX1

Community Advocate
Community Support
Messages
1,577
Reaction score
60
Points
0
Wooo....too quick.
But they ask for some reason...what should be that ? - "SUHOSIN NOT WORKING"
 

Jamesy

New Member
Messages
60
Reaction score
0
Points
0
just explain why you need it, what purpose and what script.
 

MaestroFX1

Community Advocate
Community Support
Messages
1,577
Reaction score
60
Points
0
Hi Jamesy !
I use joomla / bb. So what is the "STRONG" reason that I needa give them?
Thanks Jamesy for quick replies.
 

GamingX

Executive Team
Messages
6,355
Reaction score
3
Points
38
Just give the reason as Forums or whatever CMS is not working with a link to this thread.
 

flurgal

New Member
Messages
25
Reaction score
0
Points
0
yer im getting that too - im on stoli. Its happening on PHPBB2 and 3 and SMF. Ill reinstall them.


EDIT:
if you want my link its here-http://flashy.elementfx.com/forum/

All the damn time its happening and i cant seem to work out wats going on!
 
Last edited:

jrolson

New Member
Messages
10
Reaction score
0
Points
0
I upgraded to intermediate and still getting this error. :tear:
 

David_Tiger

New Member
Messages
278
Reaction score
0
Points
0
try re-installing the forums or whatever you are using, if that fails wait a few days for the php version to update.
If that does not work, maybe try phpv3 if you have a good enough reason to get it updated.

Tiger :D
 
Last edited:

Chris73

New Member
Messages
5,356
Reaction score
1
Points
0
Just upgrade your php via the account management panel. You currently have the basic php version.
 

dwd2000

Member
Messages
163
Reaction score
0
Points
16
I'm getting the same thing with phpBB3.
I have asked for, and got confirmation that the update to "intermediate" has been processed and now in place, but still getting the message.

Fatal error: SUHOSIN - Use of eval is forbidden by configuration in /home/dwd2000/public_html/friends-alumni.com/forums/includes/functions_module.php(328) : eval()'d code on line 328

I have 200 or more forums set up, and the thought of re-installing phpBB3 is not on the top of my favorite things to do list, especially if I'm going to have the same problem after. I can't backup the the database, because I can't get into the admin to do it, unless there is a way that re-installing phpBB3 won't write over the original database.

I have deleted all the board cookies, hoping that it might have been something simple, like a cache problem after the upgrade, but to no avail.

Is it possible that the upgrade to intermediate was set for dwd2000.x10hosting.com, and not carried down to my domain directory (friends-alumni.com) within it?

Does the server have to reboot for the changes to take effect? I don't mind waiting, if it's something simple like that.

I know the problem will get fixed. I'm just letting you know what I've done on my end and throwing some ideas out.
 

Smith6612

I ate all of the x10Pizza
Community Support
Messages
6,518
Reaction score
48
Points
48
The server doesn't have to be rebooted for the changes to take effect. If it did, downtime would be VERY often, especially if there are a lot of users all changing on a particular server. Otherwise, if you do want to back up your database, just go to MySQL Databases in cPanel or go into phpMyAdmin and download a database backup for your forum. As for reinstalling phpBB3, I believe that there is a configuration file you can change the settings to to point them to your database settings, or some sort oif script that will change it for you, so that way you won't need to start from scratch.

Otherwise, if you just signed up for Intermediate PHP, you'll need to wait about a day or two at most for it to take effect, as if you're getting eval errors, it's most likely that your account hasn't been updated yet. If it has been activacted already, you'll either need to see what the staff can do for you to fix the problem, or you'll need to "Fix" the broken forum problems. Right now though, it seems to be an error with either only having the Basic PHP backage enabled on yoru account/Intermediate PHP hasn't been fully applied yet, or there is a configuration issue.

Hope my heap of information helps you.
 

dwd2000

Member
Messages
163
Reaction score
0
Points
16
Otherwise, if you just signed up for Intermediate PHP, you'll need to wait about a day or two at most for it to take effect, as if you're getting eval errors, it's most likely that your account hasn't been updated yet. If it has been activacted already, you'll either need to see what the staff can do for you to fix the problem, or you'll need to "Fix" the broken forum problems. Right now though, it seems to be an error with either only having the Basic PHP backage enabled on yoru account/Intermediate PHP hasn't been fully applied yet, or there is a configuration issue.

Hope my heap of information helps you.

Thanks for the database info. I didn't think of that.
As for the upgrade, it says it is in place. If it's just a matter of waiting a little longer, then I will. That's not a problem. I won't post about it again, until Thursday, unless it's working before. I have included a copy of my PHP version to let you know why I'm confused.
----------------------------------------------------------------------------------

x10Hosting has secured PHP to prevent misuse and protect all of its members. If you require a less secure version of PHP for your site to run, you can request it below. Please type a detailed explanation of why you are requesting a change in your PHP version. If you do not make a reasonable argument to switch versions, your request will be denied. The advanced configuration (v3) should not be requested without an extremely good reason and advanced knowledge of PHP. Details on the versions are below.
Basic PHP Configuration - Select to view details
Most features of PHP that have the potential for abuse have been disabled in this version. This version of PHP is the default for all new accounts.
  • Memory limit and max upload file size set low
  • No mail(), eval() functions
  • No URL fopen or include
  • Variety of 'unsafe' or 'bad' functions disabled
  • PHP Version - 5.2.4
  • cURL, FTP, Socket, and MBString extensions disabled
  • /e modified with preg_replace disabled
  • No system/execution-related functions allowed, eg: exec, passthru, system
  • Magic Quotes GPC enabled
  • Extremely long variable names truncated
  • Register Globals disabled
  • File uploads disabled
  • Suhosin Path + Extension installed
Show More


Intermediate PHP Configuration - You currently have this version
This version of PHP is much more relaxed in regards to security. More features are enabled compared to the default version.
  • Mail(), eval() functions allowed
  • Memory limit and max upload filesize set moderately higher
  • URL fopen or include enabled
  • More relaxed restriction of 'unsafe' and 'bad' functions
  • PHP Version - 5.2.4
  • cURL, FTP, Socket, and MBString extensions enabled
  • /e modifier with preg_replace allowed
  • No system/execution-related functions enabled, eg: exec, passthru, system
  • Magic Quotes GPC enabled
  • Register Globals disabled
  • File uploads enabled
  • Suhosin Path + Extension installed
Show More


Advanced PHP Configuration - Select to view details
This version is very open in comparision with the previous versions. Barely any limits or restrictions are imposed.
  • Much more relaxed security precautions
  • Memory limit and max upload filesize set significantly higher
  • Basically all functions enabled, except for a few 'bad' ones
  • PHP Version - 5.2.4
  • Some system/execution-related functions enabled, eg: exec, passthru, system
  • Magic Quotes GPC enabled
  • Register Globals disabled
  • No filtered variables
  • Suhosin Path + Extension installed
Show More



Tell us why you would like to have your version of PHP changed


Once you submit your application for a PHP version change, you will receive a response within 24 hours.
 
Last edited:

champs

Banned
Messages
16
Reaction score
0
Points
0
Iam getting the same error even after upgrading my php ver.Plz help..
 

CoolFinalFan

Member
Messages
626
Reaction score
5
Points
18
I too am having this same problem but I for the life of me can't figure out how to fix the problem > PHP?
Thanks!
All this PHP stuff is greek to me, I dont' understand or know much about it!!
 

Bryon

I Fix Things
Messages
8,149
Reaction score
101
Points
48
Create your own threads, guys! It is hard to help multiple people within the same thread, things get disorganized and confusing.
 
Status
Not open for further replies.
Top