Contact Form

Status
Not open for further replies.

brando66

New Member
Messages
11
Reaction score
0
Points
1
I am making a -- well redoing -- a website for my Uncles Business, and I am using Wordpress -- the latest. I am just about finished, and was putting in a contact form so his clients and potential clients could easily email him. When I send a test email to see if everything was working correctly, the emails do not go to his gmail email account. What is going on?

Thank you.
 

nipunpcr

New Member
Messages
5
Reaction score
0
Points
1
Just a suggestion: try sending the email to the "localhost" (not Gmail), and see if that works.
 

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
Remember that you are only allowed to send from an email account that actually exists on your hosting account. You can't use the form users' email addresses as the From header; anything other than a valid address on the account will be silently discarded by the outbound spam filter. You can, however, use it as the Reply-To header. (The "no spoofing" restriction is in place to prevent common phishing-type abuse.)
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
Remember that you are only allowed to send from an email account that actually exists on your hosting account. You can't use the form users' email addresses as the From header; anything other than a valid address on the account will be silently discarded by the outbound spam filter. You can, however, use it as the Reply-To header. (The "no spoofing" restriction is in place to prevent common phishing-type abuse.)
So, what would I do to fix this? Which plugin would work?
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
I've set up wordpress contact forms many of times when i ran a personal website on Hostgator. I had no problem. Why is it so difficult right now?!
 

leafypiggy

Manager of Pens and Office Supplies
Staff member
Messages
3,819
Reaction score
163
Points
63
We require these checks because of spam and abuse.

All you should have to do is configure your script to set the email's From: header to an email account that exists on your account.
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
This is what I am getting; i've tried everything that I know how to do :(.

bool(false)

The full debugging output is shown below:

Code:
See FAQ
object(PHPMailer)#162 (69) {
["Version"]=>
string(5) "5.2.7"
["Priority"]=>
int(3)
["CharSet"]=>
string(5) "UTF-8"
["ContentType"]=>
string(10) "text/plain"
["Encoding"]=>
string(4) "8bit"
["ErrorInfo"]=>
string(68) "SMTP Error: The following recipients failed: brandonlee712@gmail.com"
["From"]=>
string(40) "theoffi7@theofficecleaningcompany.x10.mx"
["FromName"]=>
string(24) "Fast Secure Contact Form"
["Sender"]=>
string(40) "theoffi7@theofficecleaningcompany.x10.mx"
["ReturnPath"]=>
string(0) ""
["Subject"]=>
string(37) "Test email to brandonlee712@gmail.com"
["Body"]=>
string(80) "This is a test email generated by the Fast Secure Contact Form
WordPress plugin."
["AltBody"]=>
string(0) ""
["Ical"]=>
string(0) ""
["MIMEBody":protected]=>
string(81) "This is a test email generated by the Fast Secure Contact Form
WordPress plugin.
"
["MIMEHeader":protected]=>
string(633) "Date: Fri, 4 Jul 2014 15:48:27 +0000
Return-Path:
To: brandonlee712@gmail.com
From: Fast Secure Contact Form
Subject: Test email to brandonlee712@gmail.com
Message-ID:
X-Priority: 3
X-Mailer: PHPMailer 5.2.7 (https://github.com/PHPMailer/PHPMailer/)
Reply-To: brandonlee712@gmail.com
X-Sender: theoffi7@theofficecleaningcompany.x10.mx
Return-Path: theoffi7@theofficecleaningcompany.x10.mx
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

"
["mailHeader":protected]=>
string(0) ""
["WordWrap"]=>
int(0)
["Mailer"]=>
string(4) "smtp"
["Sendmail"]=>
string(18) "/usr/sbin/sendmail"
["UseSendmailOptions"]=>
bool(true)
["PluginDir"]=>
string(0) ""
["ConfirmReadingTo"]=>
string(0) ""
["Hostname"]=>
string(0) ""
["MessageID"]=>
string(0) ""
["MessageDate"]=>
string(0) ""
["Host"]=>
string(9) "localhost"
["Port"]=>
string(2) "25"
["Helo"]=>
string(0) ""
["SMTPSecure"]=>
string(0) ""
["SMTPAuth"]=>
bool(false)
["Username"]=>
string(0) ""
["Password"]=>
string(0) ""
["AuthType"]=>
string(0) ""
["Realm"]=>
string(0) ""
["Workstation"]=>
string(0) ""
["Timeout"]=>
int(10)
["SMTPDebug"]=>
int(2)
["Debugoutput"]=>
string(4) "echo"
["SMTPKeepAlive"]=>
bool(false)
["SingleTo"]=>
bool(false)
["SingleToArray"]=>
array(0) {
}
["do_verp"]=>
bool(false)
["AllowEmpty"]=>
bool(false)
["LE"]=>
string(1) "
"
["DKIM_selector"]=>
string(0) ""
["DKIM_identity"]=>
string(0) ""
["DKIM_passphrase"]=>
string(0) ""
["DKIM_domain"]=>
string(0) ""
["DKIM_private"]=>
string(0) ""
["action_function"]=>
string(0) ""
["XMailer"]=>
string(0) ""
["smtp":protected]=>
object(SMTP)#325 (12) {
["Version"]=>
string(5) "5.2.7"
["SMTP_PORT"]=>
int(25)
["CRLF"]=>
string(2) "
"
["do_debug"]=>
int(2)
["Debugoutput"]=>
string(4) "echo"
["do_verp"]=>
bool(false)
["Timeout"]=>
int(10)
["Timelimit"]=>
int(30)
["smtp_conn":protected]=>
resource(202) of type (stream)
["error":protected]=>
array(3) {
["error"]=>
string(23) "RCPT TO command failed"
["smtp_code"]=>
string(3) "550"
["detail"]=>
string(117) "Verification failed for
550-No Such User Here
550 Sender verify failed
"
}
["helo_rply":protected]=>
string(147) "250-xo1.x10hosting.com Hello localhost [127.0.0.1]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
"
["last_reply":protected]=>
NULL
}
["to":protected]=>
array(1) {
[0]=>
array(2) {
[0]=>
string(23) "brandonlee712@gmail.com"
[1]=>
string(0) ""
}
}
["cc":protected]=>
array(0) {
}
["bcc":protected]=>
array(0) {
}
["ReplyTo":protected]=>
array(0) {
}
["all_recipients":protected]=>
array(1) {
["brandonlee712@gmail.com"]=>
bool(true)
}
["attachment":protected]=>
array(0) {
}
["CustomHeader":protected]=>
array(3) {
[0]=>
array(2) {
[0]=>
string(8) "Reply-To"
[1]=>
string(24) " brandonlee712@gmail.com"
}
[1]=>
array(2) {
[0]=>
string(8) "X-Sender"
[1]=>
string(41) " theoffi7@theofficecleaningcompany.x10.mx"
}
[2]=>
array(2) {
[0]=>
string(11) "Return-Path"
[1]=>
string(41) " theoffi7@theofficecleaningcompany.x10.mx"
}
}
["lastMessageID":protected]=>
string(66) ""
["message_type":protected]=>
string(5) "plain"
["boundary":protected]=>
array(3) {
[1]=>
string(35) "b1_ebb435b4911cd7d872e59794497aa791"
[2]=>
string(35) "b2_ebb435b4911cd7d872e59794497aa791"
[3]=>
string(35) "b3_ebb435b4911cd7d872e59794497aa791"
}
["language":protected]=>
array(18) {
["authenticate"]=>
string(35) "SMTP Error: Could not authenticate."
["connect_host"]=>
string(43) "SMTP Error: Could not connect to SMTP host."
["data_not_accepted"]=>
string(30) "SMTP Error: data not accepted."
["empty_message"]=>
string(18) "Message body empty"
["encoding"]=>
string(18) "Unknown encoding: "
["execute"]=>
string(19) "Could not execute: "
["file_access"]=>
string(23) "Could not access file: "
["file_open"]=>
string(33) "File Error: Could not open file: "
["from_failed"]=>
string(35) "The following From address failed: "
["instantiate"]=>
string(36) "Could not instantiate mail function."
["invalid_address"]=>
string(15) "Invalid address"
["mailer_not_supported"]=>
string(25) " mailer is not supported."
["provide_address"]=>
string(54) "You must provide at least one recipient email address."
["recipients_failed"]=>
string(45) "SMTP Error: The following recipients failed: "
["signing"]=>
string(15) "Signing Error: "
["smtp_connect_failed"]=>
string(22) "SMTP connect() failed."
["smtp_error"]=>
string(19) "SMTP server error: "
["variable_set"]=>
string(30) "Cannot set or reset variable: "
}
["error_count":protected]=>
int(1)
["sign_cert_file":protected]=>
string(0) ""
["sign_key_file":protected]=>
string(0) ""
["sign_key_pass":protected]=>
string(0) ""
["exceptions":protected]=>
bool(false)
}
The Email debugging output is shown below:

See FAQ
SMTP -> FROM SERVER:220-xo1.x10hosting.com ESMTP Exim 4.82 #2 Fri, 04 Jul 2014 11:48:27 -0400
220-We do not authorize the use of this system to transport unsolicited,
220 and/or bulk e-mail.
CLIENT -> SMTP: EHLO theofficecleaningcompany.x10.mx
SMTP -> FROM SERVER:250-xo1.x10hosting.com Hello localhost [127.0.0.1]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-AUTH PLAIN LOGIN
250-STARTTLS
250 HELP
CLIENT -> SMTP: MAIL FROM:<theoffi7@theofficecleaningcompany.x10.mx>
SMTP -> FROM SERVER:250 OK
CLIENT -> SMTP: RCPT TO:<brandonlee712@gmail.com>
SMTP -> FROM SERVER:550-Verification failed for <theoffi7@theofficecleaningcompany.x10.mx>
550-No Such User Here
550 Sender verify failed
SMTP -> ERROR: RCPT TO command failed: 550-Verification failed for <theoffi7@theofficecleaningcompany.x10.mx>
550-No Such User Here
550 Sender verify failed
SMTP Error: The following recipients failed: brandonlee712@gmail.com
 
Last edited by a moderator:

nemesis0one

Member
Messages
34
Reaction score
2
Points
8
Although your issue above is with a contact form, have you checked if normal email's are working correctly on your wordpress installation, either by sending a email to yourself or a user sending you one.?

If it's deffo the contact form you may want to have a look here I do not receive email

Edit: Added link
 
Last edited:

Dead-i

x10Hosting Support Ninja
Community Support
Messages
6,084
Reaction score
367
Points
83
There was an issue with our email server a few hours ago. This has been resolved. Are you still getting the same error?
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
I'm still having the same issues; even with different plugins. I've tried using emails on the same domain, different domains, and a mix of both. I've used headers, etc. :-/
 

nemesis0one

Member
Messages
34
Reaction score
2
Points
8
Hi brando66,

Have you checked to see if the wordpress itself can send & receive mail, have you also tried sending from your cPanel Webmail to yourself & back to see if thats working, if the mail system has a problem possibly due to recent upgrade work being carried out of late, you can add/remove different plugins till the cows come home, NONE will ever work!

Regards
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
Yeah, I cant even email myself on NEITHER of my accounts and actually get the emails and even if it's an email on this server. I even tried sending an email to the email I was using for the site. Now my Wordpress is all messed up, I cannot even access my admin panel - not a big deal, I can fix that - but why all of a sudden is everything running into problems?
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
Wait NVM, I did get the email just took forever lol. Now time to reset up the site -- I'll report back with how it goes in this thread later this week or next.
 

jmeyersx

New Member
Messages
5
Reaction score
0
Points
1
"Remember that you are only allowed to send from an email account that actually exists on your hosting account."
Does this mean you should set up an email account even if you don't use x10 email?
Example:
domain.com added to x10 as add on domain for web site
Nameservers/dns are hosted elsewhere
MX record pointed at Exchange account: name@domain.com
Should I add that address to x10 hosting even though it will never be used?
 

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
It's the From, not the To, that has to belong to your account. If you need to reply to user-generated messages, you should use the ReplyTo header to capture their email addresses.
 

brando66

New Member
Messages
11
Reaction score
0
Points
1
I feel like and idiot. lol. Thanks for your help! It's solved. Thanks a million, I appreciate it!
 
Status
Not open for further replies.
Top