CSS isn't loading

Status
Not open for further replies.

be3le3x1

New Member
Messages
6
Reaction score
0
Points
0
Hello new here I'm just getting into web design as a hobby to learn some new skillsets. I've never hosted a site before let alone launched one and I'm having some issues.

Locally these files run as they should but on the server I there are some problems.
First I should mention when I visit my url http://be3le3.x10.mx/ instead of loading index.html it takes me to index of / the parent directory.

To the subject at hand my style sheet (style.css) isn't being read by Index.html I'm not sure why the <link in the header is correct maybe I'm missing some step.

Please help shed some light on these issues. Thank you! :wink:
 
Last edited:

Livewire

Abuse Compliance Officer
Staff member
Messages
18,168
Reaction score
215
Points
63
The problem in both cases is that this looks to have been developed on Windows, but was deployed to a Linux server which is what we use. Windows isn't CaSe SeNsItIvE, while Linux is - change the capital letter at the start of both Index.html and Style.css to a lowercase one, and it should load.

Edit: I should note that I mean in the file manager itself, change the filenames - the Style.css is referenced properly in the html file itself.


Edit 2: Good lord that's a lot of replies in 1 minute :cool:
 
Last edited:

hbazer

Member
Messages
398
Reaction score
7
Points
18
You need to re-name "Index.html" to "index.html" - note the lower case "i"

what folder is folder [ style ] in ?
 

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
Your index.html is actually named "Index.html" (with a capital "I"). Unlike Windows, Linux (most operating systems, actually) is case-sensitive, so the two names are not equivalent. As well, the file in your "style" directory is named "Style.css" (with a capital "S"). Same deal -- case-sensitivity strikes again.
 

be3le3x1

New Member
Messages
6
Reaction score
0
Points
0
Thank you for the quick replies.

@Livewire I should of known it would be an easy fix but then again I am new.
 
Status
Not open for further replies.
Top