MySQL, Database server hostname...

Discussion in 'Free Hosting' started by hatchetdown, Mar 13, 2010.

Thread Status:
Not open for further replies.
  1. hatchetdown

    hatchetdown New Member

    I'm trying to install phpBB3 (the latest stable release) and it's all going sweet until the install page asks for the database settings.

    What it asks for: (my responses in blue)
    Database type: "MySQL"

    Database server hostname or DSN: I tried both leaving blank and setting to "localhost"
    DSN stands for Data Source Name and is relevant only for ODBC installs.

    Database server port: I left blank
    Leave this blank unless you know the server operates on a non-standard port.

    Database name: the database name, as it shows in cPanel

    Database username: the database username, as it shows in cPanel

    Database password: the password for that database username, as I entered in cPanel

    Prefix for tables in database: the same as the prefix that's forced on the database name in cPanel

    It just hits me with this error:
    Could not connect to the database, see error message below.
    Access denied for user 'the_username'@'stoli.x10hosting.com' (using password: YES)


    I have made a MySQL Database in cPanel and added a new user to the database, giving it permissions for all database functions. I'm copying the database name and database username directly from the "MySQL Databases" section in cPanel. I'm not getting the password wrong.

    Other people have asked this but they all seem to get the same answer of
    "I haven't tried it, but just put 'localhost' as the DSN and it should work", which doesn't fix it for me.

    Any help would be appreciated...
    Last edited: Mar 13, 2010
  2. carl6969

    carl6969 Community Support Team Community Support

    Database host name is "localhost" (without the quotes) on X10.
    The error you are receiving suggests you may be using an incorrect user name or password.
    I suggest you double check and make sure you have that information correct.
  3. Zubair

    Zubair Community Leader Community Support

    make sure you added user to database with all privileges in cpanel
    Last edited: Mar 13, 2010
  4. hatchetdown

    hatchetdown New Member

    Yeah, I set that the first time around:
    At this point, I've tried making new databases, adding new users, linking the users to the database with all the permissions, all in "cPanel>MySQL Databases" but still get the same error in the phpBB installer...

    Does anyone know why there's a prefix pre-pended to the front of the database names?
    Like when I make a database, it automatically shows "myaccountname_" before I enter a name for it.
    Same when I make users for the database, the username shows as "myaccountname_nameientered".
    Does this happen with everyone else, would someone on stoli mind testing this?
    Last edited: Mar 13, 2010
  5. descalzo

    descalzo Grim Squeaker Community Support

    Because there are 1000's of users on the servers.
    The way to make sure there are no name clashes is to prefix the database/user names with your unique cPanel username.
    It happens to everybody.
  6. hatchetdown

    hatchetdown New Member

    Right, thanks for the insight on the naming convention.
    So is this naming system even compatible with phpBB3's installer?
    Should I even be pre-pending that prefix to the database name and usernames in phpBB at all?

    I've been on this all day, must be getting close to brute-forcing the correct settings at this stage!
    From what I can tell, I've set it up flawlessly but it just denies access apparently for no reason, I've Googled the sh*t out of it and can't find anything that directly addresses the issue anywhere!

    Could it be a restricted PHP function on new accounts?
    Could someone post a shortlist of reasons why x10's MySQL servers might deny access?
    Again, I'd highly appreciate if someone could just setup phpBB3 on a free-account, have it work, then show me what a jackass I'm being...


    RESOLVED!
    It connected when I changed the "database type" from MySQL to SQLite.
    Last edited: Mar 13, 2010
  7. Zubair

    Zubair Community Leader Community Support

    Problem solved

    ***Thread Closed***
Thread Status:
Not open for further replies.

Share This Page