SSL request

sec4qgis

New Member
Messages
4
Reaction score
0
Points
1
Hello,

I'd like to activate SSL support for my site, and I've read this post about it.

Since my site is hosted on X12, I've tried to visit https://x12.x10hosting.com:2222/user/ssl as mentioned in that post, but I get an error message that says:

Feature disabled.
This feature has been disabled. Please, contact your administrator.


Could some administrator enable this feature on my account, please?

Thank you in advance.
 

Anna

I am just me
Staff member
Messages
11,610
Reaction score
567
Points
113
SSL have now been enabled on your account.
 

sec4qgis

New Member
Messages
4
Reaction score
0
Points
1
Hello,

Thank you very much, but I'm afraid I have bother you again because although I see a new option on my control panel under Account Manager -> SSL Certificates, which points to https://x12.x10hosting.com:2222/user/ssl, if I click that new option (or I try to browse to that URL), I get a new error message that says:

Cannot Execute Your Request.
SSL is not enabled for this domain


Moreover, if I browse the HTTPS version of my site I get a warning because the certificate is not associated to my domain (it is indeed issued to x12.x10hosting.com). If I dismiss the warning I then land on a blank webpage that says "Apache is functioning normally", which is not what my HTTP site shows (if fact, it should be redirected according to a rule placed on /public_html/.htaccess).

Could you please help me, please?

Thanks.
 

Anna

I am just me
Staff member
Messages
11,610
Reaction score
567
Points
113
I enabled the option on your account.

You would need to go into "Account Manager" -> "Domain Setup" and enable SSL for any domains (click the domain name to get those options) you wish to add one for.

Here you also set weather to treat the https as a different site altogether from the http one (by default it would use the private_html folder as a symbolik link to public_html but you can chose to have them separated). You have this ("private_html setup") under "Useful Links" on the bottom left after clicking the domain name and enabling the SSL by the checkbox.

If the symbolic link option is not in use anything you want on the https version of the site needs to be in the "private_html" folder, where the http version is in the "public_html" folder.

To get a proper SSL that is valid you would need to request a free one using the option "Get automatic certificate from ACME Provider" under "Account Manager" -> "SSL Certificates", make sure to mark any subdomains you also wish the SSL to be valid for.

Image shows how it looks after you clicked the domain name.
SSL_modifydomain.png
 
Top