Use Lightspeed Web Server and MariaDB

glennemlee95

Member
Messages
59
Reaction score
2
Points
8
Lightspeed is a drop in replacement for Apache that works even faster than Nginx, uses less system resources too, less strain on the server overall, and makes websites hosted with it blazing fast.

Also, MariaDB is a drop in replacement for MySQL. Similar gains, faster than MySQL and less resource intensive.
 

Dead-i

x10Hosting Support Ninja
Community Support
Messages
6,084
Reaction score
367
Points
83
Hi,

Thank you for your feedback! Prior to the server migrations a few months ago, we used Litespeed on all our free hosting servers. We switched to Apache with Varnish to improve the performance of users' websites. :)

I'm fairly certain that we already use MariaDB on free hosting, to improve MySQL performance. ;)

Thank you,
 

glennemlee95

Member
Messages
59
Reaction score
2
Points
8
Ah, so that's why the free hosting service came to a crawl around that time. I thought it was just "overselling" or overcrowding on the servers. Was offering the Lightspeed suggestion to speed things up. Didn't realize it was changed from Lightspeed to Apache. =\

You probably should go back to Lightspeed.
 

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
Have you looked at edge-side includes, @glennemlee95 ? That should be a lot quicker than trying to tunnel through Varnish altogether. (Cache misses, even if they're deliberate, always have a cost. Edge lets you leverage cache where it's appropriate and bypasses neatly where it's not.)
 

glennemlee95

Member
Messages
59
Reaction score
2
Points
8
Have you looked at edge-side includes, @glennemlee95 ? That should be a lot quicker than trying to tunnel through Varnish altogether. (Cache misses, even if they're deliberate, always have a cost. Edge lets you leverage cache where it's appropriate and bypasses neatly where it's not.)
I honestly haven't the foggiest clue how to utilize ESI with WordPress based sites.
 

leafypiggy

Manager of Pens and Office Supplies
Staff member
Messages
3,819
Reaction score
163
Points
63
Our Varnish/Apache setup actually utilizes the litespeed PHP SAPI (lsphp_sapi) to run PHP processes, so while it is Varnish/Apache on the frontend, we're using LiteSpeed's "faster" PHP processing. In our internal testing, this setup appeared to be over 1 order of magnitude faster than our previous Litespeed setup (it may have been more, I'm not sure of the exact stats anymore)
 

glennemlee95

Member
Messages
59
Reaction score
2
Points
8
Our Varnish/Apache setup actually utilizes the litespeed PHP SAPI (lsphp_sapi) to run PHP processes, so while it is Varnish/Apache on the frontend, we're using LiteSpeed's "faster" PHP processing. In our internal testing, this setup appeared to be over 1 order of magnitude faster than our previous Litespeed setup (it may have been more, I'm not sure of the exact stats anymore)
Interesting. So essentially LightSpeed is being used as a reverse proxy? If this is the case, wouldn't Nginx and LightSpeed give an even greater boost?

(Also found out why my site was dragging so slowly, WordFence's performance setup was doing object and database caching to the disk which is highly ill advised in shared environments. Switched to W3 Total Cache and set up accordingly and enabled xcache, site's blazing again.)
 

glennemlee95

Member
Messages
59
Reaction score
2
Points
8
Nope. It's not a reverse proxy setup. Litespeed's PHP SAPI (http://www.litespeedtech.com/docs/litespeed-sapi/php-lsapi/installation) is used by apache to handle PHP execution. It's faster than normal PHP processing with Apache.

And to confirm what Dead-I said, we are using MariaDB on our servers.
I've got no further problems, I took the liberty of checking WordFence to see how it's FalconEngine caching engine actually worked and found it was cashing Database and Object caching to the disk which is, as always, ill advised on a shared hosting environment.

Here's what I did to make my site blazing again.

Entered cPanel and went into PHP Options and enabled XCache.
Disabled FalconEngine and all caching from WordFence.
Installed W3 Total Cache WordPress plugin.
Deleted CloudFlare WP plugin (Comes packaged in W3, no beating dead horses here).
Enable all caches to get saved using Xcache omitting Database and Object Caching, leaving those as dynamic as possible.
Entered CloudFlare details.
Enabled SEO by Yoast "Cutting Edge" extension

So the problem wasn't you guys, it was my choice of scripts and I apologize. I should know better.
 
Top