Wordpress site unable to send mails

Status
Not open for further replies.

theteamk

Member
Messages
94
Reaction score
1
Points
8
Hi,

I have been trying to send out mails from my WP site. The mails are for registration purposes or are sent out if someone fills in the "contact form". I installed the Email Logs plugin and was able to confirm that my site was sending out the mails. I went through earlier threads too. The contents of the mail do not include the word "testing" or "test" for the purpose.

Are the x10hosting servers sending out the mail? Or are they being blocked because of spam issues. I can assure you that none of the contents of the mail can be classified as spam. I have not exceeded the hourly limit of 100 mails too. So, can anyone help me in sorting out this issue?

URL: http://androguider.com
 

aquari24

New Member
Messages
12
Reaction score
1
Points
3
I just tested mine works fine. Do you have your mail settings correct in the CPanel ?
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
I just tested mine works fine. Do you have your mail settings correct in the CPanel ?
I don't know why, but I don't get emails from my website. I have not touched any settings in the CPanel. The email logs from my WP site confirm that the mails are being sent out, but I believe that the x10hosting's spam filters are somewhere blocking them. Someone from the support staff needs to debug this for further info. I can guarantee that no spam mails are being sent out.
 

aquari24

New Member
Messages
12
Reaction score
1
Points
3
What i meant was, if you dont have your email account and forwarder set correctly in the CPanel, you wont get any mail.
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
I looked into that too. I was hoping that someone from the support staff would look into this problem please. It's been more than 2 weeks and the problem still remains unresolved. Pls help.


Regards
Krittin
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
It's been about a month now. My problem remains unresolved. Will anyone take a look into this issue?
 

Derek

Community Support Force
Community Support
Messages
12,882
Reaction score
186
Points
63
It's been about a month now. My problem remains unresolved. Will anyone take a look into this issue?

I would suggest using an external smtp server such as mailgun or something like that to handle the emails.
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
I would suggest using an external smtp server such as mailgun or something like that to handle the emails.

I don't have to send out that many mails. It's just the registration mails which have to be sent out. So, I don't look forward to buying any mail services. Additionally, I don't think that the x10hosting servers permit SMTP.

Can you put the systems in debugging mode and find which rule my mails are breaking? As I have mentioned in the OP, none of my mails can be categorised as spam. I can guarantee that to you. We just need to find which rule is being broken when the mails are being sent out and then fix them accordingly. What do you say?
 

Derek

Community Support Force
Community Support
Messages
12,882
Reaction score
186
Points
63
I don't have to send out that many mails. It's just the registration mails which have to be sent out. So, I don't look forward to buying any mail services. Additionally, I don't think that the x10hosting servers permit SMTP.

Can you put the systems in debugging mode and find which rule my mails are breaking? As I have mentioned in the OP, none of my mails can be categorised as spam. I can guarantee that to you. We just need to find which rule is being broken when the mails are being sent out and then fix them accordingly. What do you say?

Mailgun is free up to 10,000 emails. You can set the smtp server up in the WP admin control panel to handle your emails.
https://www.mailgun.com/pricing
 

essellar

Community Advocate
Community Support
Messages
3,295
Reaction score
227
Points
63
You can, yes, but external SMTP is blocked on Free Hosting servers so all mail can be funnelled through the outbound spam filter. You'd need to use a transactional mail service like Mandrill, which can be accessed with an HTTP API - or have the real problem resolved.
 

Dead-i

x10Hosting Support Ninja
Community Support
Messages
6,084
Reaction score
367
Points
83
Hi,

Sorry I missed this. Please can you confirm if you are still seeing this problem? It looks like the spam filter was blocking these emails being sent. If you are still having this issue, however, please send me a PM with the email address you're signing up to WordPress with.

Thank you,
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
Hi,

Sorry I missed this. Please can you confirm if you are still seeing this problem? It looks like the spam filter was blocking these emails being sent. If you are still having this issue, however, please send me a PM with the email address you're signing up to WordPress with.

Thank you,

I waited for a few days, but the problem still persists. I PMed you. Please check.
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
Hi,

Sorry I missed this. Please can you confirm if you are still seeing this problem? It looks like the spam filter was blocking these emails being sent. If you are still having this issue, however, please send me a PM with the email address you're signing up to WordPress with.

Thank you,

Did you check your inbox? The problem has not been solved yet.

Please do reply.

Regards
Krittin
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
Hi,

Sorry I missed this. Please can you confirm if you are still seeing this problem? It looks like the spam filter was blocking these emails being sent. If you are still having this issue, however, please send me a PM with the email address you're signing up to WordPress with.

Thank you,

I have been waiting for a reply from you since ages. Please do keep an eye on the conversation I started with you.

Regards
Krittin
 

Dead-i

x10Hosting Support Ninja
Community Support
Messages
6,084
Reaction score
367
Points
83
Hi,

After a lot of testing, I think I've nailed this down to an issue in a certain pattern that a spam rule is checking emails against, which is wrongly classifying your email as spam. I'm checking this with higher staff before I do anything else, and we should be able to fix this.

As a side note, I made a test account on your site from the email in my signature, but please feel free to delete it.

Thank you,
 

theteamk

Member
Messages
94
Reaction score
1
Points
8
Hi,

After a lot of testing, I think I've nailed this down to an issue in a certain pattern that a spam rule is checking emails against, which is wrongly classifying your email as spam. I'm checking this with higher staff before I do anything else, and we should be able to fix this.

As a side note, I made a test account on your site from the email in my signature, but please feel free to delete it.

Thank you,

Thank you very much. Hope it get's fixed soon. Please do post a reply to this thread when you guys have fixed it.
 
Status
Not open for further replies.
Top