CloudFlare HTTPS Issue

Status
Not open for further replies.

rontek

New Member
Messages
15
Reaction score
0
Points
1
Hi, I am using CloudFlare Edge to secure my site and this was setup a few years back when X10 CPanel CloudFlare was available. My Cloudflare still works with www, but is missing the root level SSL setting.

My account is blitzcoder.x10host.com

Recently I just found out that another x10 account has managed to enter and use my root domain with a self-signed insecure certificate and url:

a12luismc.x10host.com

Please help and would like to restore my root domain cloudflare setup and settings back.

Thanks.
 
Last edited:

rontek

New Member
Messages
15
Reaction score
0
Points
1
@Anna

Hi, can you please look into this as this is clearly a malicious activity coming from this user a12luismc.x10host.com

using my root domain with a self-signed invalid certificate.
 

Anna

I am just me
Staff member
Messages
11,264
Reaction score
527
Points
113
I'm actually suspecting it is something to do with apache and how the new system handles https requests where the certificate is missing for any reason, rather then maliccous activity.

I'm however sending this up to higher admins as I don't have the proper access to investigate further.
 

rontek

New Member
Messages
15
Reaction score
0
Points
1
Thanks Anna, looking forward to the update in getting this resolved.
 

mycoo368

Member
Messages
183
Reaction score
4
Points
18
Free accounts do not get SSL, make sure the Cloudflare setting is at Flexible and that Universal SSL is enabled.
 

rontek

New Member
Messages
15
Reaction score
0
Points
1
Free accounts do not get SSL, make sure the Cloudflare setting is at Flexible and that Universal SSL is enabled.


Thanks. Yes, that is why I am reporting a CloudFlare issue and have already set both. Actually I have already reset my Universal SSL as the CF Team instructed earlier and now it's pending validation.

@Anna

My site root domain certificate is now pending validation from CloudFlare. We are still seeing this error and it seems to be preventing from validating.

Any updates on this?

atBRgdg.png
 

cjptomas80

Member
Messages
254
Reaction score
6
Points
18
Turn your cloudflare ssl settings to full not full(strict) since we can not change the ssl certificate manually on x10hosting.

Update: I didn't read the whole thread sorry. This is wrong information.
 

rontek

New Member
Messages
15
Reaction score
0
Points
1
Hi, @Anna still waiting for any feedback on this as it's been 3 days already.
 
Last edited:
Status
Not open for further replies.
Top