Domain name change

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Hi guys,

I know this has been posted a lot but I'm struggling to get my domain to change properly.

My site is: http://students.pcriot.com/
and I've bought the domain www.thestudentwire.com from GoDaddy and I can't seem to get it to link properly.

I managed to link it so that every page on students.pcriot.com was thestudentwire.com but I want it so that when you click a link it changes to thestudentwire.com/aboutus etc.

Any help would be great. Thank you
 

leafypiggy

Manager of Pens and Office Supplies
Staff member
Messages
3,819
Reaction score
163
Points
63
You'll want to change the site url in your configuration/admin section for the software you're using.
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
How do I do that?

Sorry I'm a complete noob when it comes to all this, I thought it would be easy :\
 

Anna

I am just me
Staff member
Messages
11,414
Reaction score
546
Points
113
The how would depend on what script you are using, I would recommend that you check for support on that part from the script vendors you got your script from.

Optionally, if you tell what script you use someone here might be able to point you in the right direction, there's no official support for third party scripts though, so there's no guarantee anyone at these forums are familiar with the script.
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Well I've got PHPBB forum installed on my website, when I log in the X10hosting control panel it shows students.pcriot.com as my MAIN domain but I want www.thestudentwire.com to be my main one.

I've tried fiddling around with godaddy settings and the X10Hosting control panel setting but can't seem to get it to work
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Okay that looks pretty easy to do, what do I need to setup on the godaddy side of things?
 

caftpx10

Well-Known Member
Messages
1,535
Reaction score
114
Points
63
Well, you would need to change the nameservers (choose the custom option) on the GD domain management page to X10's nameservers, you will need the following link for the information: https://www.x10hosting.com/wiki/Nameservers
After that, you would need to add the domain name either as an add-on or parked domain. I don't know the difference as of now but it seems that add-on for me works perfectly.
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Okay so I changed the nameservers on godaddy last night and today I logged into x10's control panel and added my domain as an add-on. I've left it a few hours and now just checked and I just get an error when trying to go to http://www.thestudentwire.com/
Could someone please login to their godaddy account and let me know their DNS ZONE FILE settings? My A(Host) section is empty as well as AAAA (IPv6 Host) and I've no idea if they are supposed to have something in.

I'm sorry for all this I don't know why it's being to difficult
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Okay so I've screenshot what I've got so hopefully you can tell me where I'm going wrong :p
First here's my godaddy settings:
Help1.png

And here are the DNS settings:
help2.png
help3.png


And I've added my godaddy domain as an Addon domain on the x10hosting control panel:

help4.png



Can anyone please tell me where I'm going wrong? :p

Thank guys, really appreciate the help
 

caftpx10

Well-Known Member
Messages
1,535
Reaction score
114
Points
63
Ah. You know when you've added the domain? By default, it places the actual URL after '/public_html'. You'll need to make it so that the add-on domain directory path is only /public_html rather than what it currently is.

Kinda scratch that. I think you will need to change your cPanel theme to the other one which will have more options and make it much easier to manage. The redirection thing set up on the TLD shouldn't be there at all if you want to make it work everywhere.
 
Last edited:

bdistler

Well-Known Member
Prime Account
Messages
3,534
Reaction score
196
Points
63
Can anyone please tell me where I'm going wrong?
to add to @AngusThermopyle post - and be sure you know how to 'get' into [ cPanel x3 ] theme...
clicking the "Switch Theme" button at the top on the screen (after you log-in) - you can choose between [ x10Hosting Basic ] and [ cPanel x3 ] themes
 

AngusThermopyle

Active Member
Messages
319
Reaction score
52
Points
28
Works for me. It takes a while for the updates to percolate through the Web.

Do not change anything, or you might reset everything back to Square 1 .
 

caftpx10

Well-Known Member
Messages
1,535
Reaction score
114
Points
63
When I visit that URL (with the WWW.), it does a redirect to http://www.thestudentwire.com/home/USER_REMOVED_JUST_TO_BE_SAFE/public_html/www.students.pcriot.com/
Note that the bolded is just me replacing the actual username.
Anyway, it looks as if the redirect is still in place, but just on the www. one and will remain like that for a while for some. Hopefully, that'll eventually sort itself out as Angus has mentioned.
 

jamiew23

New Member
Messages
10
Reaction score
0
Points
1
Hey guys, I haven't changed anything at all. Just turned on my laptop went to go to http://www.thestudentwire.com/ and it doesn't work.

What makes it worse is that thestudentwire.com with the www isn't working now either!
Any ideas?
 
Top